1. 程式人生 > >LA 4349 樹狀陣列解決簡單組合數--思維

LA 4349 樹狀陣列解決簡單組合數--思維

Description


N(3N20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1T20) , indicating the number of test cases, followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N , the number of players. Then N distinct integers a1, a2...aN follow, indicating the skill rank of each player, in the order of west to east ( 1ai100000 , i= 1...N ).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1
3 1 2 3
Sample Output

1
題意:
一條大街上住著n個乒乓球愛好者,經常組織比賽。每個人都有一個技能值ai,每場比賽需要3個人:兩名選手和一名裁判。規定裁判位置必須在兩個選手的中間,而且技能值也必須在兩個選手的中間,問一共能組織多少種比賽
思路:
考慮第i個人當裁判的情形,假設a1到a[i-1]中有ci個比ai小,那麼就有(i-1)-ci個比ai大,同理,假設a[i+1]到an中有di個比ai小,那麼就有(n-i)-di個比ai大,然後根據乘法原理和加法原理,i當裁判有ci(n-i-di)+(i-ci-1)*di,這樣問題就轉化為求c,d

#include<iostream>
#include<set>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<vector>
#include<cmath>
#include<queue>
using namespace std;
typedef long long ll;
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define mem(a,b) memset(a,b,sizeof a);
const int N = 1e5+7;
const int INF=0x3f3f3f3f;
int a[N];
int c[N];
int sum1[N],sum2[N];
int lowbit(int x)
{
    return x&-x;
}
int Sum(int x){
    int res=0;
    while(x>0){
        res+=c[x];
        x-=lowbit(x);
    }
    return res;
}
void add(int x,int val){
    while(x<=100000){
        c[x]+=val;
        x+=lowbit(x);
    }
    return ;
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        rep(i,1,n) scanf("%d",&a[i]);
        memset(c,0,sizeof c);
        for(int i=1;i<=n;i++){//sum1記錄的是在0--i-1之間有多少個比a[i]小的數;
            add(a[i],1);
            sum1[i]=Sum(a[i]-1);
        }
        memset(c,0,sizeof c);
        for(int i=n;i>=1;i--){//sum2記錄的是在0--i-1之間有多少個比a[i]大的數;
            add(a[i],1);
            sum2[i]=Sum(a[i]-1);
        }
        ll ans=0;
        for(int i=1;i<=n;i++){
            ans+=sum1[i]*(n-i-sum2[i])+sum2[i]*(i-1-sum1[i]);
        }
        printf("%lld\n",ans);
    }
    return 0;
}