1. 程式人生 > >[字尾陣列 + 二分] 求最長不重疊重複子串 POJ - 1743

[字尾陣列 + 二分] 求最長不重疊重複子串 POJ - 1743

Musical Theme

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 35051   Accepted: 11632

Description

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings. 
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 

  • is at least five notes long 
  • appears (potentially transposed -- see below) again somewhere else in the piece of music 
  • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)


Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 
Given a melody, compute the length (number of notes) of the longest theme. 
One second time limit for this problem's solutions! 

Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 
The last test case is followed by one zero. 

Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.

Sample Input

30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0

Sample Output

5

Hint

Use scanf instead of cin to reduce the read time.

 

 

#include <iostream>
#include <cstdio>
using namespace std;
const int mn = 20010, ml = 175;

int x[mn], y[mn], c[mn];
int sa[mn], Rank[mn], height[mn];
bool cmp(int *r, int a, int b, int l)
{
	return r[a] == r[b] && r[a + l] == r[b + l];
}
void da(int str[], int n, int m)
{
	n++;
	for (int i = 0; i < m; i++)
		c[i] = 0;
	for (int i = 0; i < n; i++)
		c[x[i] = str[i]]++;
	for (int i = 1; i < m; i++)
		c[i] += c[i - 1];
	for (int i = n - 1; i >= 0; i--)
		sa[--c[x[i]]] = i;
	
	for (int j = 1; j <= n; j <<= 1)
	{
		int p = 0;
		for (int i = n - j; i < n; i++)
			y[p++] = i;
		for (int i = 0; i < n; i++)
			if (sa[i] >= j)
			y[p++] = sa[i] - j;
		
		for (int i = 0; i < m; i++)
			c[i] = 0;
		for (int i = 0; i < n; i++)
			c[x[y[i]]]++;
		for (int i = 1; i < m; i++)
			c[i] += c[i - 1];
		for (int i = n - 1; i >= 0; i--)
			sa[--c[x[y[i]]]] = y[i];
		swap(x, y);
		p = 1;
		x[sa[0]] = 0;
		for (int i = 1; i < n; i++)
			x[sa[i]] = cmp(y, sa[i - 1], sa[i], j) ? p - 1: p++;
		if (p >= n)
			break;
		m = p;
	}
	int k = 0;
	n--;
	for (int i = 0; i <= n; i++)
		Rank[sa[i]] = i;
	for (int i = 0; i < n; i++)
	{
		if (k)
			k--;
		int j = sa[Rank[i] - 1];
		while (str[i + k] == str[j + k])
			k++;
		height[Rank[i]] = k;
	}
}

bool check(int n, int k)
{
	int l = n + 10, r = -1;
	bool flag = 0;
	for (int i = 2; i <= n; i++)
	{
		if (height[i] < k) 	// 下一組相同字首 另一長度為k的可能子串
		{
			flag = 0;
			l = n + 10, r = -1;
			continue;
		}
		
		// 有相同子串時 找到最前和最後的出現位置
		if (height[i] >= k)
		{
			if (flag == 0)
			{
				l = min(l, sa[i - 1]);
				r = max(r, sa[i - 1]);
				flag = 1;
			}
			if (flag == 1)
				l = min(l, sa[i]),
				r = max(r, sa[i]);
		}
		if (r - l > k)	// 相同子串起始位置>k 不重疊 不連續(連續 >=k)
			return 1;
	}
	return 0;
}

int a[mn], b[mn];
int main()
{
	#ifndef ONLINE_JUDGE
		freopen("D:\\in.txt", "r", stdin);
	#endif // ONLINE_JUDGE
	
	int n;
	while (~scanf("%d", &n) && n)
	{
		for (int i = 0; i < n; i++)
			scanf("%d", &a[i]);
		for (int i = 1; i < n; i++)
			b[i - 1] = a[i] - a[i - 1] + 87;  // 處理為非負數
		
		da(b, n - 1, ml);
		
		int ans = 0;
		int l = 0, r = n - 1;
		while (l <= r)	// 二分驗證當前長度是否可行
		{
			int mid = (l + r) / 2;
			if (check(n - 1, mid))
			{
				//cout << mid << endl;
				ans = mid;
				l = mid + 1;
			}
			else 
				r = mid - 1;
		}
		
		if (ans < 4)
			printf("0\n");
		else
			printf("%d\n", ans + 1);
	}
	return 0;
}