1. 程式人生 > >PAT-甲級 1034.Head of a Gang

PAT-甲級 1034.Head of a Gang

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

題目描述:

 

題目思路:

 

題目核心程式碼:

//計算團伙的頭目、成員個數、總通話時間
void DFS(int member, int& head, int& numMember, int& totalValue){
    vis[member] = true;
    numMember++;
    if(weight[member]>weight[head]) head=member;
    for(int i=0; i<numPerson; i++){
        if(G[member][i]>0){
            totalValue += G[member][i];//先加權值
            G[member][i]=G[i][member]=0;    //加完就刪,防止回頭
            if(vis[i]==false){

                DFS(i, head, numMember, totalValue);
            }
        }
    }
}
//遍歷圖,找到頭目和團伙個數,獲取每個團伙的資訊
void DFSTraversal(){
    for(int i=0; i<numPerson; i++){
        if(vis[i]==false){
            int head = i;
            int numMember = 0;
            int totalValue = 0;
            DFS(i, head, numMember, totalValue);
            if(numMember>2 && totalValue>k){
                Gang[intToString[head]] = numMember;
                //intToString在這裡用,轉換為團伙頭目名稱
            }
        }
    }
}

題目完整程式碼:

#include <iostream>
#include <string>
#include <map>

using namespace std;

const int maxn = 2010;           //通話記錄的二倍

map<int,string> intToString;//人員編號和人員名稱鍵值對
map<string, int> stringToInt;
map<string, int> Gang;      //團伙頭目,團伙人數,也可以用結構體來做

int G[maxn][maxn]={0};      //鄰接矩陣
int weight[maxn] = {0};     //每個人通話時間總和
int n,k,numPerson=0;        //通訊條數,閾值,人員總數
bool vis[maxn] = {false};     //該成員是否被訪問

//計算團伙的頭目、成員個數、總通話時間
void DFS(int member, int& head, int& numMember, int& totalValue){
    vis[member] = true;
    numMember++;
    if(weight[member]>weight[head]) head=member;
    for(int i=0; i<numPerson; i++){
        if(G[member][i]>0){
            totalValue += G[member][i];//先加權值
            G[member][i]=G[i][member]=0;    //加完就刪,防止回頭
            if(vis[i]==false){

                DFS(i, head, numMember, totalValue);
            }
        }
    }
}

//遍歷圖,找到頭目和團伙個數,獲取每個團伙的資訊
void DFSTraversal(){
    for(int i=0; i<numPerson; i++){
        if(vis[i]==false){
            int head = i;
            int numMember = 0;
            int totalValue = 0;
            DFS(i, head, numMember, totalValue);
            if(numMember>2 && totalValue>k){
                Gang[intToString[head]] = numMember;
                //intToString在這裡用,轉換為團伙頭目名稱
            }
        }
    }
}

//判斷str是否出現過,如果沒有則新增,如果新增過返回他的編號
int Change(string str){
    if(stringToInt.find(str) != stringToInt.end()){     //找到了
        return stringToInt[str];    //返回編號
    }
    else{      //找不到
        stringToInt[str] = numPerson;
        intToString[numPerson] = str;
        return numPerson++;
    }
}

int main()
{
    string str1, str2;
    int w;

    cin>>n>>k;
    for(int i=0; i<n; i++){
        cin>>str1>>str2>>w;
        int id1 = Change(str1);
        int id2 = Change(str2);
        weight[id1] += w;
        weight[id2] += w;
        G[id1][id2] += w;   //建立圖,插入邊
        G[id2][id1] += w;
        //這裡先加權值再進行遍歷
    }

    DFSTraversal();//遍歷

    cout<<Gang.size()<<endl;

    map<string, int>::iterator it;
    for(it=Gang.begin(); it!=Gang.end(); it++){//遍歷Gang
        cout<<it->first<<" "<<it->second<<endl;
    }

    return 0;
}