1. 程式人生 > >hdu3746 KMP-next陣列的應用

hdu3746 KMP-next陣列的應用

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16309    Accepted Submission(s): 6754


Problem Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.  

 

Input The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).  

 

Output For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.  

 

Sample Input 3 aaa abca abcde    

 

Sample Output 0 2 5   題意:最少需要加入多少個字元才能讓整個字串完全匹配 1、先找出這個字串中迴圈次數最多的字串(長度為n),並求出迴圈次數m和這個字串長度len,輸出len-m*n就行了
//HD3746
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
const int N = 1000005;
int i, n, m, t, sum;
char T[N], P[N];//P[]是需要比較的字串,T[]是被比較的字串
int next1[N];
void getnext(char  *P, int *next1)
{
    int j = 0;
    int k = -1;
    next1[0] = -1;
    while (j <= m)
    {
        if (k == -1 || P[j] == P[k])
        {
            next1[++j] = ++k;
        }
        else
        {
            k = next1[k];
        }
    }
}
int main()
{
    cin >> t;
    while (t--)
    {
        scanf("%s", P);
        m = strlen(P);
        getnext(P, next1);
        n = m - next1[m];
        if (n != m && m%n == 0)
            cout << "0" << endl;
        else
            cout << n - next1[m] % n << endl;
    }
    //system("pause");
    return 0;
}

相似題目https://www.cnblogs.com/-citywall123/p/10034261.html