1. 程式人生 > >HDU 2119 - Matrix (二分匹配最小點集覆蓋)

HDU 2119 - Matrix (二分匹配最小點集覆蓋)

Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.

Input

There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.

Output

For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.

Sample Input

3 3 
0 0 0
1 0 1
0 1 0
0

Sample Output

2

題意:

    就是每次可以刪除一行或者一列數,問最少幾次可以把所有的1都變成0,也就是都刪完。

思路:

       把行號放在二分圖左邊點集,列號放在右邊點集.如果(i,j)格子是1,那麼就連左i與右j的無向邊。

       就是求該二分圖的最小邊覆蓋點集.使得每條邊都被至少1個點覆蓋。

       最小覆蓋集大小 = 最大匹配數。

程式碼:

#include<stdio.h>
#include<string.h>
int map[110][110],book[110],match[110];
int n,m;
int dfs(int u)
{
	int i;
	for(i=1;i<=m;i++)
	{
		if(book[i]==0&&map[u][i]==1)
		{
			book[i]=1;
			if(match[i]==0||dfs(match[i]))
			{
				match[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,a,b,sum;
	while(scanf("%d",&n)!=EOF&&n)
	{
		scanf("%d",&m);
		sum=0;
		memset(book,0,sizeof(book));
		memset(match,0,sizeof(match));
		memset(map,0,sizeof(map));
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
			{
				scanf("%d",&map[i][j]);
			}
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
				book[j]=0;
			if(dfs(i))
				sum++;
		}
		printf("%d\n",sum);
	}
}