1. 程式人生 > >【ZOJ2002】Copying Books(二分+貪心)

【ZOJ2002】Copying Books(二分+貪心)

題目連結

Copying Books


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < bk-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.


Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000.


Output

For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character ('/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.


Sample Input

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100


Sample Output

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

 

【題意】

給出一個數列有n個數,要求用分割分把這個數列分成m段,不能改變原數列的順序。每段至少一個數。求使得加和最大的那段的加和最小的劃分方案。如果有多組解的話先要保證第一段和儘量小,若仍有多組解,要先保證第二段和儘量小,以此類推。

【解題思路】

因為這個數列是有序的,並且要求最大的最小可以考慮二分。將數列和作為二分上限,數列的最大值作為二分的下限,二分和,然後檢驗這個和能將數列分成幾份,若比給定的m大,說明這個和不夠大,則l=mid+1。當然為了保證如果有多解,需要保證第一段的和儘量小這一條件,需要從後面往前分,因為這樣如果分成的段數比m小的話就在前面加就好啦。

【程式碼】

#include<bits/stdc++.h>
using namespace std;
const int maxn=505;
int a[maxn],n,m,vis[maxn];
int check(int x)
{
    int sum=0,cnt=0;
    memset(vis,0,sizeof(vis));
    for(int i=n-1;i>=0;i--)
    {
        sum+=a[i];
        if(sum>x)
        {
            sum=a[i];
            cnt++;
            vis[i]=1;
        }
    }
    return cnt+1;
}
int binarysearch(int l,int r)
{
    while(l<r)
    {
        int mid=(l+r)/2;
        int t=check(mid);
        if(t>m)l=mid+1;
        else r=mid;
    }
    return r;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int l=0,r=0;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            l=max(l,a[i]);
            r+=a[i];
        }
        int t=binarysearch(l,r);
        int num=check(t);
        for(int i=0;i<n&& num<m;i++)
        {
            if(!vis[i])
            {
                num++;
                vis[i]=1;
            }
        }
        for(int i=0;i<n;i++)
        {
            printf("%d",a[i]);
            if(vis[i])printf(" /");
            if(i<n-1)printf(" ");
        }
        printf("\n");
    }
    return 0;
}