1. 程式人生 > >hdu 1269 迷宮城堡【強連通模板】

hdu 1269 迷宮城堡【強連通模板】

Problem Description
為了訓練小希的方向感,Gardon建立了一座大城堡,裡面有N個房間(N<=10000)和M條通道(M<=100000),每個通道都是單向的,就是說若稱某通道連通了A房間和B房間,只說明可以通過這個通道由A房間到達B房間,但並不說明通過它可以由B房間到達A房間。Gardon需要請你寫個程式確認一下是否任意兩個房間都是相互連通的,即:對於任意的i和j,至少存在一條路徑可以從房間i到房間j,也存在一條路徑可以從房間j到房間i。
 

Input
輸入包含多組資料,輸入的第一行有兩個數:N和M,接下來的M行每行有兩個數a和b,表示了一條通道可以從A房間來到B房間。檔案最後以兩個0結束。
 

Output
對於輸入的每組資料,如果任意兩個房間都是相互連線的,輸出"Yes",否則輸出"No"。
 

Sample Input
3 3
1 2
2 3
3 1
3 3
1 2
2 3
3 2
0 0
 

Sample Output
Yes
No

強連通模板題:


#include<cstring>
#include<string>
#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<map>
#include<vector>
#include<stack>
#define inf 0x3f3f3f3f
#include<queue>
#include<set>
using namespace std;
typedef long long ll;
const int N=1e4+5;
const int M=1e5+5;
 
struct node
{
    int v,ne;
}edge[M];
int head[N];
int dfn[N],low[N],vis[N];
int n,m,e,top,flag;
stack<int>sta;
 
void init()
{
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    e=0;top=0;flag=0;
}
 
void add(int a,int b)
{
    edge[e].v=b;
    edge[e].ne=head[a];
    head[a]=e++;
}
 
void tarjan(int x)
{
    low[x]=dfn[x]=++top;
    sta.push(x);
    vis[x]=1;
    for(int i=head[x];i!=-1;i=edge[i].ne)
    {
        if(!dfn[edge[i].v])//如果沒訪問該店
        {
            tarjan(edge[i].v);
            low[x]=min(low[x],low[edge[i].v]);
        }
        else if(vis[edge[i].v])//如果該點在棧中
            low[x]=min(low[x],dfn[edge[i].v]);
    }
    if(low[x]==dfn[x])
    {
        sta.pop();
        vis[x]=0;
        flag++;//這道題 如果flag 即強連通分量為 1 ,表示該圖強連通
    }
}
 
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        if(!n&&!m) break;
        while(!sta.empty())
            sta.pop();
        int a,b;
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d %d",&a,&b);
            add(a,b);
        }
        for(int i=1;i<=n;i++)
        {
            if(!dfn[i])//如果沒有訪問過該點
                tarjan(i);
        }
        if(flag<=1) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}