1. 程式人生 > >SDUTOJ3311資料結構實驗之串三:KMP應用

SDUTOJ3311資料結構實驗之串三:KMP應用

資料結構實驗之串三:KMP應用 (PS:這題巨坑  嗚嗚嗚。。)

https://acm.sdut.edu.cn/onlinejudge2/index.php/Home/Contest/contestproblem/cid/2710/pid/3311

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

有n個小朋友,每個小朋友手裡有一些糖塊,現在這些小朋友排成一排,編號是由1到n。現在給出m個數,能不能唯一的確定一對值l和r(l <= r),使得這m個數剛好是第l個小朋友到第r個小朋友手裡的糖塊數?

Input

首先輸入一個整數n,代表有n個小朋友。下一行輸入n個數,分別代表每個小朋友手裡糖的數量。

之後再輸入一個整數m,代表下面有m個數。下一行輸入這m個數。

Output

 如果能唯一的確定一對l,r的值,那麼輸出這兩個值,否則輸出-1

Sample Input

5
1 2 3 4 5
3
2 3 4

Sample Output

2 4

Hint

Source

windream

思路:

這道題考察的也是kmp演算法,不過,需要注意的是:求得是唯一的一對l和r,需要再加一個判斷,看是否是唯一存在的即可。

也有一些坑點  比如222666 和22的情況  這也就註定你的第二次匹配的位置問題

 

#include <bits/stdc++.h>
using namespace std;
int a[10000001], b[10000001];
int nextt[1000001];
void get_next(int b[], int n)
{
    nextt[0] = -1;
    int j = -1, i = 0;
    while (i < n) // i < n-1 也可以
    {
        if (j == -1 || b[i] == b[j])
        {
            i++;
            j++;
            nextt[i] = j;
        }
        else
            j = nextt[j]; // 失配回溯
    }
}
int kmp(int a[], int b[], int m, int n)
{
    int i = 0, j = 0;
    // cout<<j<<endl;
    while (i < m && j < n)
    {
        if (j == -1 || a[i] == b[j]) //j==-1 不能少  因為可能失配回溯到j-1
        {
            i++;
            j++;
        }
        else
            j = nextt[j]; // 失配回溯
    }
    // cout<<j<<endl;
    if (j >= n)
        return i + 1 - n;
    // 或return i + 1 - n;  都一樣
    else
        return -1;
}
int main()
{
    int m, n;
    scanf("%d", &m);
    for (int i = 0; i < m; i++)
        scanf("%d", &a[i]);

    scanf("%d", &n);
    for (int i = 0; i < n; i++)
        scanf("%d", &b[i]);

    get_next(b, n);
    int ans1 = kmp(a, b, m, n);
    if (ans1 == -1)
        printf("-1\n");
    else
    {
        int ans2 = kmp(a + ans1, b, m, n);
        // 這個地方必須是  a + ans1  考慮22266 和 22 這種情況  兩種匹配的情況有共同元素
        if (ans2 == -1)
            printf("%d %d\n", ans1, ans1 + n - 1);
        else
            printf("-1\n");
    }

    return 0;
}