1. 程式人生 > >2016ACM/ICPC亞洲區青島站(區域賽練習)

2016ACM/ICPC亞洲區青島站(區域賽練習)

A - Relic Discovery

Recently, paleoanthropologists have found historical remains on an island in the Atlantic Ocean. The most inspiring thing is that they excavated in a magnificent cave and found that it was a huge tomb. Inside the construction,researchers identified a large number of skeletons, and funeral objects including stone axe, livestock bones and murals. Now, all items have been sorted, and they can be divided into N types. After they were checked attentively, you are told that there are AiAi items of the i-th type. Further more, each item of the i-th type requires BiBi million dollars for transportation, analysis, and preservation averagely. As your job, you need to calculate the total expenditure. 

Input

The first line of input contains an integer T which is the number of test cases. For each test case, the first line contains an integer N which is the number of types. In the next N lines, the i-th line contains two numbers AiAi and BiBi as described above. All numbers are positive integers and less than 101.

Output

For each case, output one integer, the total expenditure in million dollars. 

Sample Input

1
2
1 2
3 4

Sample Output

14

沒啥好說的!

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
using namespace std;
int main()
{
	int t,n,a,b;
	long long int sum=0;
	scanf("%d",&t);
	while(t--)
	{
		sum=0;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			sum=sum+(a*b);
		}
		printf("%lld\n",sum);
	}
	return 0;
}

C - Pocky

Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.  While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.  Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point. 

Input

The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150. 

Output

For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

Sample Input

6
1.0 1.0
2.0 1.0
4.0 1.0
8.0 1.0
16.0 1.0
7.00 3.00

Sample Output

0.000000
1.693147
2.386294
3.079442
3.772589
1.847298

找規律吧!

log以e為底2的對數等於0.693147 。

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
using namespace std;
int main()
{
    int t;
    double l,d;
    scanf("%d",&t);
    while(t--)
    {
    	scanf("%lf%lf",&l,&d);
    	if(l<=d)
    	  puts("0.000000");
    	else
    	{
    		printf("%.6lf\n",log(l/d)+1);
		}
	}
	return 0;
}