1. 程式人生 > ># 俱樂部每日一練 T^T(2)

# 俱樂部每日一練 T^T(2)

俱樂部每日一練 T^T(2)

Description

T ^ T這個很像一個流淚的表情是不是!其實,它是T的T次方啦~。當T比較大的時候T^T會非常大,現在只要你求這個數一共有多少位就可以了。

Input

輸入包括多組測試資料,每個測試資料只有一個數字T(0<T<2^{31})T(0<T<2
31
)。

Output

請輸出T^T的一共有多少位數。

Sample Input 1

3
5
Sample Output 1

2
4
數的位數=log(10)T^T=T*log(10)T
注意資料範圍
程式碼:

#include<stdio.h>
#include<math.h>
int main()
{
    double a,t;
    long long n;
    while(scanf("%lld",&n)!=EOF)
    {
        a=n*log10(n);
        printf("%lld\n",(long long)(a+1));
    }
    return 0;
}