1. 程式人生 > >PAT (Advanced Level)-1107 Social Clusters(並查集)

PAT (Advanced Level)-1107 Social Clusters(並查集)

1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8 3: 2 7 10 1: 4 2: 5 3 1: 4 1: 3 1: 4 4: 6 8 1 5 1: 4

Sample Output:

3 4 3 1

社交圈 是由人組成且圈中的人彼此有愛好相同

模擬樣例:愛好分為1 3 4 5 6 7 8 10 這幾種

一共8個人(從0開始記) 共同愛好4下 有1 3 5 7這四個人 共同愛好3下 有 024 這三個人 雖然6與2 有共同愛好5 但6無法歸入024的圈中 因此 共 3個圈 

用並查集 新開一個數組為愛好 初始化為0  若i人愛好t hobby[t]=i 此時這個愛好t 由i做老大 後來有人再喜歡這個愛好自動歸順i人

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
vector<int> clus,f;
int hobby[1001];
int getf(int v)
{
	return f[v]==v?v:f[v]=getf(f[v]);
}
void merge(int u,int v)
{
	int t1,t2;
	t1=getf(u);
	t2=getf(v);
	if(t1!=t2)
	{
		f[t1]=t2;
	}
}
int main() 
{
	int n;
	scanf("%d",&n);
	clus.resize(n+1);
	f.resize(n+1);	
	for(int i=1;i<=1001;i++)f[i]=i;
	for(int i=1;i<=n;i++)
	{
		int k;
		scanf("%d:",&k);
		for(int j=0;j<k;j++)
		{
			int t;
			scanf("%d",&t);
			if(hobby[t]==0)
				hobby[t]=i;
			merge(i,getf(hobby[t]));
		}
	}
	int cnt=0;
	for(int i=1;i<=n;i++)
	{
		clus[getf(i)]++;
	}
	for(int i=1;i<=n;i++)
	{
		if(clus[i])cnt++;
	}
	sort(clus.begin(),clus.end(),greater<int>());
	printf("%d\n",cnt);
	for(int i=0;i<cnt;i++)
	{
		printf("%d",clus[i]);
		if(i!=cnt-1)printf(" ");
	}
}