1. 程式人生 > >PAT (Advanced Level) 1014 Waiting in Line (30 分)

PAT (Advanced Level) 1014 Waiting in Line (30 分)

1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.
For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.
At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).
The next line contains K positive integers, which are the processing time of the K customers.
The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

Code

#include <iostream>
#include <queue>
#include <vector>
#include <algorithm>
#include <iomanip>
#define INF 0x3f3f3f3f

using namespace std;

struct Client
{
	int total_serve_time; // 顧客所需服務時間
	int res_serve_time; // 顧客剩餘所需服務時間
	int finish_time; // 顧客服務完成時間
	Client() : total_serve_time(-1), res_serve_time(-1), finish_time(0){}
	Client(int t_time) : total_serve_time(t_time), res_serve_time(t_time), finish_time(0) {}
};

queue<int> window[20]; // 模擬銀行視窗
vector<Client> cli_vec; // 儲存客戶資訊
int M, N, K, Q;

int find_window() // 找到客戶剩餘所需服務時間最小的視窗號
{
	int index = -1, time = INF;
	for (int i = 0; i < N; i++)
	{
		if (!window[i].empty())
		{
			int temp = window[i].front();
			if (cli_vec[temp].res_serve_time < time)
			{
				time = cli_vec[temp].res_serve_time;
				index = i;
			}
		}
	}
	return index;
}

int main()
{
	// M maxNum of per line
	// N number of window
	// K num of customers
	// Q num of query list
	cin >> N >> M >> K >> Q;
	int yellow_line = N * M; // 黃線中最大容量
	for (int i = 0; i < K; i++)
	{
		int serve_time;
		cin >> serve_time;
		cli_vec.push_back(Client(serve_time));
	}
	for (int i = 0; i < min(yellow_line, K); i++) // 注意K不一定大於yellow_line
	{												// 不然會出現段錯誤
		window[i%N].push(i);
	}
	int curr_time = 0; // 當前時間
	int curr_client = min(yellow_line,K); // 現在佇列中客戶數
	int next_client = curr_client; // 下一個要加入佇列的客戶號
	while (curr_client > 0)
	{
		int wi = find_window();
		int ci = window[wi].front();
		Client c = cli_vec[ci];
		vector<int> less_window; // 儲存這次有客戶完成業務的視窗號
		for (int i = 0; i < N; i++)
		{
			if (!window[i].empty())
			{
				int temp = window[i].front();
				cli_vec[temp].res_serve_time -= c.res_serve_time;
				cli_vec[temp].finish_time = curr_time + c.res_serve_time;
				if (cli_vec[temp].res_serve_time == 0) // 如果客戶完成業務
				{
					window[i].pop();
					curr_client--;
					less_window.push_back(i);
				}
			}
		}
		curr_time += c.res_serve_time; // 更新當前時間
		sort(less_window.begin(), less_window.end(), 
			[](const int wi1, const int wi2)->bool {
			if (window[wi1].size() != window[wi2].size())
				return window[wi1].size() < window[wi2].size();
			else
				return wi1 < wi2;
		}); // 把視窗人數少的,視窗號小的排在前面,優先接納客戶
		for (int i = 0; i < less_window.size(); i++)
		{
			int wi = less_window[i];
			if (next_client < K)
			{
				window[wi].push(next_client);
				next_client++;
				curr_client++;
			}
		}
	}
	for (int i = 0; i < Q; i++)
	{
		int qi; cin >> qi;
		int serve_time = cli_vec[qi - 1].total_serve_time;
		int finish_time = cli_vec[qi - 1].finish_time;
		int h, m;
		h = 8 + finish_time / 60;
		m = finish_time % 60;
		if (finish_time - serve_time >= 540) cout << "Sorry" << endl; // 注意在17點前開始業務的客戶不輸出Sorry,
																	  //只有在17點之後開始業務的輸出Sorrry
		else cout << setw(2) << setfill('0') << h << ':' << setw(2) << setfill('0') << m << endl;
	}
	return 0;
}

思路

總體思路是這樣的,按照時間來,每次都找出當前正在辦理業務的客戶中,所剩需要服務時間最短的,更新所有視窗客戶所剩需要服務的時間的資訊,將剩餘所需服務時間為0的客戶移出佇列,再將後續客戶按照佇列最短,佇列號最小的順序,加入佇列。

以上