1. 程式人生 > >Super Jumping! Jumping! Jumping! (求最大的遞增子序列的和,不用連續)

Super Jumping! Jumping! Jumping! (求最大的遞增子序列的和,不用連續)

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 

The game can be played by two or more than two players. It consists of a chessboard(棋盤)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.  Your task is to output the maximum value according to the given chessmen list. 

Input

Input contains multiple test cases. Each test case is described in a line as follow: N value_1 value_2 …value_N  It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.  A test case starting with 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the maximum according to rules, and one line one case. 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

解題心得:題意:求最大的遞增子序列的和,不用連續,例如(1,5,2),那麼(1,2)也算他的遞增子序列。 

  我剛開始做了一遍,忽略了不用連續這個問題,結果發現好簡單,提交就是不對,應當注意這裡。

  這個還是得用動態規劃去做,最後的最優結果是由上一步的結果加上上一次的決策。n個數,由n-1個數的結果加上第n個數。n-1個數由n-2個數的結果。。。。。

  推倒最後,前兩個數的的結果就很容易求了.以數列(3,2,4,2,3,6)為例。

下標i 0 1 2 3 4 5
a[i] 3 2 4 2 3 6
sum[i] 3 2 7 2 5 13
ans 0 3 7 7 5 13

  我覺得這個題動態規劃思想一定要理解那兩句‘重要程式碼’。

  另外發現一個事情,max()函式不用單獨再去定義了,c++裡面可以直接呼叫,不用再寫#define max(a,b) a>b ? a:b 這一句了。

#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int N=1000001;
const int inf=0x3f3f3f;
int a[N];
int b[N];
int dp[N];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        for(int i=0; i<n; i++)
            cin>>a[i];
        int ans;
        b[0]=a[0];
        ans=b[0];
        for(int i=0; i<n; i++)
        {
            b[i]=a[i];
            for(int j=0; j<i; j++)
            {
                if(a[j]<a[i])
                {
                    b[i]=max(b[i],b[j]+a[i]);
                }
            }
            ans=max(ans,b[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}