1. 程式人生 > >PAT(Advanced Level)1001 A+B Format

PAT(Advanced Level)1001 A+B Format

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991
/*	Sample Input:-1000000 9
	Sample Output:-999,991
*/
#include <iostream>
#include <algorithm> 
#include <string>
using namespace std;
int main(){
	int a, b, sum;
	cin >> a >> b;
	sum = a + b;
	string s = to_string(sum);//轉化為字元型陣列
	if(s[0] == '-') {
		cout << "-";
		s.erase(0, 1); //刪除從下標從0開始的一個字元 
	}
	reverse(s.begin(), s.end());//由於新增","從後往前加的,所以需要先轉置一下
	int len = (int)s.size();
	for(int i = 3; i < len; i += 3) { //每隔3個數字插入一個"," 
		s.insert(i, ",");
		i++; //插完的","也算一個位置的,故要往後移一位的
		len++; //插入","以後s的總長度要加1 
	}	
	reverse(s.begin(), s.end());
	cout << s; 
	return 0;
}

string字串操作:

  • erase 原型: (1)string& erase ( size_t pos = 0, size_t n = npos ); (2)iterator erase ( iterator position ); (3)iterator erase ( iterator first, iterator last ); 用法: (1)erase(pos,n); 刪除從pos開始的n個字元,比如erase(0,1)就是刪除第一個字元 (2)erase(position);刪除position處的一個字元(position是個string型別的迭代器) (3)erase(first,last);刪除從first到last之間的字元(first和last都是迭代器)

  • insert 原型: string &insert(int p0, const char *s); string &insert(int p0, const char *s, int n); string &insert(int p0,const string &s); string &insert(int p0,const string &s, int pos, int n); //前4個函式在p0位置插入字串s中pos開始的前n個字元 string &insert(int p0, int n, char c);//此函式在p0處插入n個字元c iterator insert(iterator it, char c);//在it處插入字元c,返回插入後迭代器的位置 void insert(iterator it, const_iterator first, const_iterator last);//在it處插入[first,last)之間的字元 void insert(iterator it, int n, char c);//在it處插入n個字元c

  • to_string函式 C++11 新增方法 string to_string (int val); string to_string (long val); string to_string (long long val); string to_string (unsigned val); string to_string (unsigned long val); string to_string (unsigned long long val); string to_string (float val); string to_string (double val); string to_string (long double val)

  • reverse函式 陣列轉置 reverse(v.begin(),v.end())