1. 程式人生 > >HDU-4054.Hexadecimal View(模擬,十六進位制轉換)

HDU-4054.Hexadecimal View(模擬,十六進位制轉換)

M - M

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Hexadecimal is very important and useful for computer programmers. You are requested to provide a hexadecimal view for given data. The hexadecimal view is made up of one or more rows. Every row except the last one represents 16 characters. Each row consists of three columns separated by a space:  * addr: the 4-digit hexadecimal beginning address of this row.  * dump: the hexadecimal representation of this row, separating every two characters by a whitespace. If there are less than 16 characters in the last row, pad it with spaces.  * text: the ASCII translation of this row, with uppercase characters converted to lowercase and lowercase characters converted to uppercase.  Use lowercase for the letter digits. See sample for more details. 

Input

There are multiple test cases. Each line is a test case. The line is made up of no less than 1 and no more than 4096 printable characters including spaces. 

Output

For each test case, output its hexadecimal view. Do not output any extra spaces after the last character of text. 

Sample Input

Hex Dump #include <cstdio> printf("Hello, World!\n"); main = do getLine >>= print . sum . map read . words

Sample Output

0000: 4865 7820 4475 6d70 hEX dUMP 0000: 2369 6e63 6c75 6465 203c 6373 7464 696f #INCLUDE <CSTDIO 0010: 3e > 0000: 7072 696e 7466 2822 4865 6c6c 6f2c 2057 PRINTF("hELLO, w 0010: 6f72 6c64 215c 6e22 293b ORLD!\N"); 0000: 6d61 696e 203d 2064 6f20 6765 744c 696e MAIN = DO GETlIN 0010: 6520 3e3e 3d20 7072 696e 7420 2e20 7375 E >>= PRINT . SU 0020: 6d20 2e20 6d61 7020 7265 6164 202e 2077 M . MAP READ . W 0030: 6f72 6473 ORDS

稍微注意下輸出的格式就好啦~~ 這是我比賽後補的題目,我隊友比賽的時候開的還是很快的,感謝隊友哈哈哈

【題意】

中間四位四位輸出的是兩個字元為一組的ascii碼轉換成16進位制數後的數,然後後面每一行輸出16個字元(大小寫互換一下)

【通過程式碼】

#include<cstdio>
#include<iostream>
#include<cstring>
const int maxn = 1e5 + 5;
using namespace std;
char str[5000];
int main()
{
    int t = 0,len;
    while(cin.getline(str,maxn))
    {
        t = 0;
        len = strlen(str);
        for(t = 0;t < len;t += 16)
        {
            printf("%04x: ",t);
            for(int i = t;i< t + 16;i += 2)
            {
                if(i != t )
                    printf(" ");//除了第一個,後面每兩個輸出前都有個空格
                if(i < len) printf("%02x",str[i]);
                else    printf("  ");//如果後面沒有字元了,就用2個空格代替佔位
                if(i + 1 < len) printf("%02x",str[i+1]);
                else    printf("  ");
            }
            cout<<" ";
            for(int i=t;i<t+16&&i<len;i++)
            {
                if(str[i]>='a'&&str[i]<='z') printf("%c",toupper(str[i]));
                else if(str[i]>='A'&&str[i]<='Z')  printf("%c",tolower(str[i]));
                else printf("%c",str[i]);
            }
            cout<<endl;
        }
    }
    return 0;
}