1. 程式人生 > >HDU 1072 Nightmare

HDU 1072 Nightmare

分類

HDU BFS DFS 搜尋 剪枝

題意

走迷宮,並有炸到限時,初始值是6秒,為0秒時爆炸,每走一步消耗一秒,如果能在最短的時間內走出來輸出最短的時間,否則輸出-1。

0代表牆、1代表路、2代表起點、3代表終點,4代表時間重置

樣例輸入輸出

Sample Input

3
3 3
2 1 1
1 1 0
1 1 3
4 8
2 1 1 0 1 1 1 0
1 0 4 1 1 0 4 1
1 0 0 0 0 0 0 1
1 1 1 4 1 1 1 3
5 8
1 2 1 1 1 1 1 4 
1 0 0 0 1 0 0 1 
1 4 1 0 1 1 0 1 
1 0 0 0 0 3 0 1 
1 1 4 1 1 1 1 1 

Sample Output

4
-1
13

想法

DFS,BFS都可,但想法不同,(不知道為什麼,可能是我太菜了,我dfs用bfs的剪枝方法,即炸彈位置只能走一次,錯了);
兩種方法都需理解一點:
同一個炸彈位置當第二次走到時說明已不是最優解。
BFS法:
處理走到同一個炸彈位置方法:第一次走到炸彈的位置時,將該炸彈設定為0(即牆),將不會再一次走到此處。
然後就是BFS了。++比DFS慢,因為會走一些重複的++
DFS法:
記憶化搜尋。
記錄走過該點的時間與炸彈剩餘爆炸時間。
然後去掉同樣走到該位置時所用時間更久和剩餘爆炸時間更短的路。

程式碼

BFS(不太會用)

#include<bits/stdc++.h>
using namespace std; const int maxn = 1111; const int INF = 0x3f3f3f3f; int n,m,MIN,sx,sy; int Map[11][11]; int xx[4] = {0,1,0,-1}; int yy[4] = {1,0,-1,0}; struct position{ int x,y,step,t; }pos; int bfs(){ queue<position> q; q.push(pos); while(!q.empty()){ pos = q.front(); q.pop(); for
(int i=0;i<4;i++){ position p; p.x = pos.x+xx[i]; p.y = pos.y+yy[i]; p.step = pos.step+1; p.t = pos.t-1; if(p.x>=1&p.x<=n&&p.y>=1&&p.y<=m&&Map[p.x][p.y]!=0&&p.t>0){ if(Map[p.x][p.y]==3){ return p.step; } if(Map[p.x][p.y]==4){//重新計時,並且設定為牆,因為下一次到這一定不是最優解 p.t = 6; Map[p.x][p.y] = 0; } q.push(p); } } } return -1; } int main() { freopen("in.txt","r",stdin); int T; cin >> T; while(T--){ scanf("%d%d",&n,&m); for(int i=1;i<=n;i++){ for(int j=1;j<=m;j++){ scanf("%d",&Map[i][j]); if(Map[i][j]==2){ pos.x=i; pos.y=j; pos.step=0; pos.t=6; Map[i][j] = 0;//設定為牆,因為下一次回到起點一定不是最優解 } } } printf("%d\n",bfs()); } return 0; }

DFS(就是遞迴,經常用)

#include<bits/stdc++.h>
using namespace std;
const int maxn =  1111;
const int INF = 0x3f3f3f3f; 
int n,m,MIN,sx,sy;

int dis[11][11],Time[11][11];//記憶化搜尋,用以判斷是否走過 
int Map[11][11];
int xx[4] = {0,1,0,-1};
int yy[4] = {1,0,-1,0};
void dfs(int x,int y,int step,int t){
	if(t == 0||step > MIN) return ;//這裡小於0和小於等於0是不一樣的,錯了幾次 
	if(Map[x][y]==4) t=6;//走到炸彈,可以重置時間為6秒 
	if(Map[x][y]==3) {//走到終點 
		if(step<MIN) MIN = step;
		return;
	}
	if(step>=dis[x][y]&&t<=Time[x][y]) return ;//重點,如果當前位置我之前走過,
						//而且我當前步數比之前走的時候多並且剩餘時間比之前少,就沒必要繼續了 
	dis[x][y] = step;
	Time[x][y] = t;
	for(int i=0;i<4;i++){
		int nx = x+xx[i];
		int ny = y+yy[i];
		if(nx>=1&&nx<=n&&ny>=1&&ny<=m&&Map[nx][ny]!=0)
			dfs(nx,ny,step+1,t-1);
	}
}

int main() {
	freopen("in.txt","r",stdin);
	int T;
	cin >> T;
	while(T--){
		scanf("%d%d",&n,&m);
		for(int i = 1;i<=n;i++){
			for(int j=1;j<=m;j++){
				scanf("%d",&Map[i][j]);
				dis[i][j] = INF;
				Time[i][j]= 0;
				if(Map[i][j]==2){
					sx = i;
					sy = j;
				}
			}
		}
		MIN = INF;
		dfs(sx,sy,0,6);
		if(MIN==INF) printf("-1\n");
		else printf("%d\n",MIN);
	}
	return 0;
}