1. 程式人生 > >HDU-5119 Happy Matt Friends(dp)

HDU-5119 Happy Matt Friends(dp)

Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.
Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 10 6).

In the second line, there are N integers ki (0 ≤ k i ≤ 10 6), indicating the i-th friend’s magic number.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
Sample Input
2
3 2
1 2 3
3 3
1 2 3
Sample Output
Case #1: 4
Case #2: 2

Hint
In the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.

我在牛客上做過一個類似的題,但是就是怎麼也想不到,就是一個簡單的dp方程
dp[i][j] = dp[i - 1][j] + dp[i - 1][j ^ a[i]];
dp[i][j]代表前i個異或值為j的組合數,這個狀態怎麼轉移呢?分為取a[i] 和 不取a[i]兩種狀態,dp[i - 1][j] 表示不取a[i],dp[i - 1][j ^ a[i]]表示取a[i]因為j ^ a[i] ^ a[i] = j;

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define mp make_pair
#define pb push_back
#define fi first
#define se second
const int N = 1 << 20;

int a[50];
LL dp[50][N];

int main()
{
    int t;
    scanf("%d",&t);
    int cnt = 0;
    while(t--)
    {
        cnt++;
        int n,m;
        scanf("%d %d",&n,&m);
        for(int i = 1;i <= n;++i){
            scanf("%d",&a[i]);
        }
        memset(dp,0,sizeof(dp));
        dp[0][0] = 1;
        for(int i = 1;i <= n;++i){
            for(int j = 0;j < (1 << 20);++j){
                dp[i][j] = dp[i - 1][j] + dp[i - 1][j ^ a[i]];
            }
        }
        LL ans = 0;
        for(int i = m;i < (1 << 20);++i){
            ans += dp[n][i];
        }
        printf("Case #%d: ",cnt);
        printf("%lld\n",ans);
    }
    return 0;
}