1. 程式人生 > >[PAT甲級]1013. Battle Over Cities (25)(圖的遍歷,統計強連通分量個數)

[PAT甲級]1013. Battle Over Cities (25)(圖的遍歷,統計強連通分量個數)

1013. Battle Over Cities (25)

原題連結
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

題目大意:

  • 給出n個城市,城市間有m條路,k個要檢查的城市
  • 假如這k個城市被攻佔,所有相關的路線全部癱瘓,要使其他城市保持連通,至少需要修繕多少條路

    思路:

  • 其實這是考察圖的問題,刪除圖的一個節點,是其他節點成為連通圖,至少需要新增多少條線

  • 新增最少的路線,就是連通分量數-1
    (例:n個互相獨立的連通分量組成一個連通圖,只需要連n-1條線就可以)
  • 這道題最重要就是求除去圖的一個節點後 剩餘的連通分量的數目
  • 利用鄰接矩陣v儲存路線,用visit陣列表示城市是否被遍歷過
  • 對於每個被佔領的城市,將其表示為遍歷過的狀態true即可
  • 利用深度優先遍歷dfs計算連通分量數目

程式碼:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
int v[1001][1001];//記錄連通路線 預設為0 不連通
bool visit[1001];//記錄是否遍歷過
int n;//n個城市
void dfs(int node){
    visit[node] = true;
    for(int i=1; i<=n; i++){
        if(visit[i]==false && v[node][i] == 1){
            dfs(i);
        }
    }
}
int main()
{
    int m, k, a, b;//m條路 k個要檢查的城市 ab為路線起點終點
    scanf("%d%d%d", &n, &m, &k);
    for(int i=0; i<m; i++){
        scanf("%d%d", &a, &b);
        v[a][b] = 1;
        v[b][a] = 1;
    }
    for(int i=0; i<k; i++){
        fill(visit, visit+1001, false);//重置visit 所有城市未被遍歷
        int temp = 0;
        scanf("%d", &temp);
        visit[temp] = true;//被攻佔的城市,標記為true
        int cnt = 0;//記錄連通分量
        for(int j=1; j<=n; j++){
            if(visit[j] == false){
                dfs(j);
                cnt++;//連通分量+1
            }
        }
        printf("%d\n", cnt-1);//思路第二條
    }
    return 0;
}