1. 程式人生 > >【笨方法學PAT】1013 Battle Over Cities(25 分)

【笨方法學PAT】1013 Battle Over Cities(25 分)

一、題目

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing Knumbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

二、題目大意

對於圖,求連通分量的個數。

三、考點

圖、DFS

四、解題思路

1、使用二維陣列儲存圖;

2、使用 visit 標記訪問過的城市,遍歷所有的城市,計算連通分量的個數;

3、需要修的路,是連通分量的個數 -1。

五、程式碼

#include<iostream>
#define N 1010
#define INF 99999999
using namespace std;

int e[N][N], visit[N];
int to_repair;
int n, m, k;

void dfs(int index) {
	for (int i = 1; i <= n; ++i) {
		if (visit[i] == false && e[index][i] == 1 && i != to_repair) {
			visit[i] = true;
			dfs(i);
		}
	}
}

int main() {
	fill(e[0], e[0] + N*N, INF);
	
	//讀取資料
	cin >> n >> m >> k;
	while (m--) {
		int a, b;
		cin >> a >> b;
		e[a][b] = e[b][a] = 1;
	}
	
	while (k--) {
		cin >> to_repair;
		
		//DFS
		fill(visit, visit + N, false);
		int cnt = 0;
		visit[to_repair] = true;
		for (int i = 1; i <= n; ++i) {
			if (visit[i] == false) {
				dfs(i);
				cnt++;
			}
		}
		cout << cnt - 1 << endl;
	}
	system("pause");
	return 0;
}