1. 程式人生 > >【笨方法學PAT】1012 The Best Rank(25 分)

【笨方法學PAT】1012 The Best Rank(25 分)

一、題目

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C

M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

二、題目大意

給定學生的C、M、E三科成績,求C、M、E、平均成績A中的最好名次。

三、考點

排序

四、解題思路

這道題很繁瑣,需要排序的東西太多了:ACME四個成績,還要分別求對應的Rank。如果分開求,程式碼會很長,使用struct巢狀陣列,可以減小工作量;

1、使用 struct 儲存資料,按照ACME儲存成績;

2、使用 cmp_flag 全域性變數儲存排序的科目,排序完成之後,求 Rank ,成績相同排名相同,否則與當前的位置相同;

3、之後判斷的時候,先判斷 ID 是否存在,存在的話,迴圈4個專案,獲得最小排名。

五、程式碼

#include<iostream>
#include<algorithm>
#include<vector>
#define N 1000010
#define INF 99999999
using namespace std;
struct node {
	int id;
	//a c m e
	int g[4],rank[4];
};
int cmp_flag = 0;
bool cmp(node n1, node n2) {
	return n1.g[cmp_flag] > n2.g[cmp_flag];
}
int main() {
	int n, m;
	cin >> n >> m;
	vector<node> vec(n);
	bool show[N] = { false };

	//讀取資料
	for (int i = 0; i < n; ++i) {
		cin >> vec[i].id >> vec[i].g[1] >> vec[i].g[2] >> vec[i].g[3];
		vec[i].g[0] = (vec[i].g[1] + vec[i].g[2] + vec[i].g[3]) / 3;
		show[vec[i].id] = true;
	}

	//排名
	for (int i = 0; i < 4; ++i) {
		cmp_flag = i;
		sort(vec.begin(), vec.end(), cmp);

		vec[0].rank[i] = 1;
		for (int j = 1; j < vec.size(); ++j) {
			//成績相等,排名相同
			if (vec[j].g[i] == vec[j - 1].g[i]) {
				vec[j].rank[i] = vec[j - 1].rank[i];
			}
			//成績不相等,排名靠後
			else
				vec[j].rank[i] = j + 1;
		}
	}

	while (m--) {
		int id;
		cin >> id;

		//沒有找到
		if (show[id]==false) {
			cout << "N/A"<<endl;
			continue;
		}

		//排名
		int best_rank = INF;
		int best_id = 0;
		char int2char[4] = { 'A','C','M','E' };

		//排序之後順序改變,需要找到 id 的位置
		node tmp;
		for (int i = 0; i < vec.size(); ++i) 
			if (id == vec[i].id) {
				tmp = vec[i];
				break;
			}
		//尋找最小rank
		for (int i = 0; i < 4; ++i) {
			if (tmp.rank[i] < best_rank) {
				best_rank = tmp.rank[i];
				best_id = i;
			}
		}
		cout << best_rank << " " << int2char[best_id] << endl;
	}

	system("pause");
	return 0;
}