1. 程式人生 > >PAT (Advanced Level) Practice 1094 The Largest Generation (25 分)樹的層次遍歷

PAT (Advanced Level) Practice 1094 The Largest Generation (25 分)樹的層次遍歷

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

 輸出樹中最多節點的個數和所在的層數。

程式碼如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
const int maxn=105;
int n,m;
vector<int>v[maxn];
int par[maxn];
int height,num;
void traverse (int x)
{
    queue<int>q;
    height=1; num=1;
    q.push(x);
    int k=0;
    while (!q.empty())
    {
        k++;
        int Size=q.size();
        if(num<Size)
        {
            num=Size;
            height=k;
        }
        while (Size--)
        {
            int t=q.front();
            q.pop();
            for (int i=0;i<v[t].size();i++)
            {
                q.push(v[t][i]);
            }
        }
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    memset (par,-1,sizeof(par));
    for (int i=0;i<m;i++)
    {
        int x,num;
        scanf("%d%d",&x,&num);
        for (int j=0;j<num;j++)
        {
            int y;
            scanf("%d",&y);
            v[x].push_back(y);
            par[y]=x;
        }
    }
    int root;
    for (int i=1;i<=n;i++)
        if(par[i]==-1)
        {
            root=i;
            break;
        }
    traverse(root);
    printf("%d %d\n",num,height);
    return 0;
}