1. 程式人生 > >HDU-6318 Swaps and Inversions(求逆序數+樹狀陣列)

HDU-6318 Swaps and Inversions(求逆序數+樹狀陣列)

Swaps and Inversions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 356    Accepted Submission(s): 129


 

Problem Description

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.

Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.

Output

For every test case, a single integer representing minimum money to pay.

Sample Input

3 233 666

1 2 3

3 1 666

3 2 1

Sample Output

0

3

Source

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define clr(a) memset(a,0,sizeof(a))
#define lowbit(x) x&(-x)

const int MAXN = 1e5+10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9+7;
const int N = 1010;

int n,x,y;
int tree[MAXN*4],b[MAXN];
struct node{
    int val,pos;
}p[MAXN];
bool cmp(node a,node b){
    return a.val < b.val;
}
void add(int x,int v){
    while(x<=n){
        tree[x] += v;
        x += lowbit(x);
    }
}
int get_sum(int x){
    int sum = 0;
    while(x){
        sum += tree[x];
        x -= lowbit(x);
    }
    return sum;
}
int main(){
    while(scanf("%d%d%d",&n,&x,&y)!=EOF){
        clr(p);clr(tree);clr(b);
        for(int i=1;i<=n;i++){
            scanf("%d",&p[i].val);
            p[i].pos = i;
        }
        sort(p+1,p+n+1,cmp);
        int cnt = 1;
        for(int i=1;i<=n;i++){
            if(i != 1 && p[i].val != p[i-1].val)
                cnt++;
            b[p[i].pos] = cnt;
        }
        LL sum = 0;
        for(int i=1;i<=n;i++){
            add(b[i],1);
            sum += (i - get_sum(b[i]));
        }
        sum *= (LL)min(x,y);
        printf("%lld\n",sum);
    }
    return 0;
}