1. 程式人生 > >【poj2406】Power Strings——KMP

【poj2406】Power Strings——KMP

題目:

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 41220 Accepted: 17140

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

描述:求字串s的迴圈節個數

題解:

if (len % (len - nxt[len]) == 0)       //  看整個長度len能分解成x個這種串。
			ans = len / (len - nxt[len]);

程式碼:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
using namespace std;
const int maxn = 1000005;
char text[maxn];
int nxt[maxn];
int main()
{
	while (scanf("%s", text) != EOF)
	{
		if (text[0] == '.')break;
		int len = strlen(text);
		for (int i = 0, j = -1; i <= len; i++, j++)
		{
			nxt[i] = j;
			while (~j && text[i] != text[j])
				j = nxt[j];
		}
		
		int ans = 1;
		if (len % (len - nxt[len]) == 0)       //  看整個長度len能分解成x個這種串。
			ans = len / (len - nxt[len]);
		printf("%d\n", ans);
	}

	return 0;
}