1. 程式人生 > >構造矩陣【看似高大上,實際水題一道】

構造矩陣【看似高大上,實際水題一道】

對於一個N × M的整數矩陣A,小Hi知道每一行的整數之和依次是P1, P2, ... PN,每一列的整數整數之和依次是Q1, Q2, ... QM。  

你能構造出一個矩陣A,滿足每個元素Aij都是非負的,並且滿足上述行列之和嗎?

Input

第一行包含兩個整數N和M。  

第二行包含N個整數,P1, P2, ... PN。  

第三行包含M個整數,Q1, Q2, ... QM。  

輸入保證有解。  

1 ≤ N, M ≤ 100  

1 ≤ Pi, Qi ≤ 100000

Output

輸入一個N × M的矩陣,滿足題目中的要求。如果有多解,你可以輸出任意一個。

Sample Input

3 3  
15 15 15  
15 15 15

Sample Output

8 1 6  
3 5 7  
4 9 2

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define lowbit(x) ( x&(-x) )
#define pi 3.141592653589793
#define e 2.718281828459045
using namespace std;
typedef unsigned long long ull;
typedef long long ll;
const int maxN = 105;
int N, M, P[maxN], Q[maxN], ans[maxN][maxN], now_P[maxN], now_Q[maxN];
void init()
{
    memset(ans, 0, sizeof(ans));
    memset(now_P, 0, sizeof(now_P));
    memset(now_Q, 0, sizeof(now_Q));
}
int main()
{
    while(scanf("%d%d", &N, &M)!=EOF)
    {
        for(int i=1; i<=N; i++) scanf("%d", &P[i]);
        for(int i=1; i<=M; i++) scanf("%d", &Q[i]);
        for(int i=1; i<=N; i++)
        {
            for(int j=1; j<=M; j++)
            {
                ans[i][j] = min(P[i], Q[j]);
                P[i] -= ans[i][j];
                Q[j] -= ans[i][j];
            }
        }
        for(int i=1; i<=N; i++)
        {
            for(int j=1; j<=M; j++)
            {
                printf("%d%c", ans[i][j], j==M?'\n':' ');
            }
        }
    }
    return 0;
}