1. 程式人生 > >HDU 1159.Common Subsequence【動態規劃DP】【3月8】

HDU 1159.Common Subsequence【動態規劃DP】【3月8】

Common Subsequence

Problem Description A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input abcfbc abfcab programming contest abcd mnp
Sample Output 4 2 0

題目大意:給出兩個字串,求兩個字串的最長公共字串。

思路:慢慢重心開始有貪心轉向動態規劃了,這題就是簡單的動態規劃題。以題目的第一組測試資料為例。abcfbc abfcab。

輔助空間變化示意圖


可以看出:

F[i][j]=F[i-1][j-1]+1;(a[i]==b[j])

F[i][j]=max(F[i-1][j],F[i][j-1])(a[i]!=b[j]);

n由於F(i,j)只和F(i-1,j-1), F(i-1,j)和F(i,j-1)有關, 而在計算F(i,j)時, 只要選擇一個合適的順序, 就可以保證這三項都已經計算出來了, 這樣就可以計算出F(i,j). 這樣一直推到f(len(a),len(b))就得到所要求的解了.

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
int f[1100][1100];
char s1[1000], s2[1000];
int len1, len2;
int main()
{
    while(scanf("%s %s", s1, s2) != EOF)
    {
        len1 = strlen(s1);
        len2 = strlen(s2);
        memset(f, 0, sizeof(f));
        for(int i = 1;i <= len1; ++i)
        {
            for(int j = 1;j <= len2; ++j)
            {
                if(s1[i-1] == s2[j-1]) f[i][j] = f[i-1][j-1]+1;
                else
                {
                    f[i][j] = max(f[i-1][j], f[i][j-1]);
                }
            }
        }
        cout << f[len1][len2] << endl;
    }
    return 0;
}