1. 程式人生 > >poj 2192 Zipper(DFS+剪枝)

poj 2192 Zipper(DFS+剪枝)

Zipper
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16825 Accepted: 5998

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. 

For example, consider forming "tcraete" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: tcraete 

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: catrtee 

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree". 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. 

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive. 

Output

For each data set, print: 

Data set n: yes 

if the third string can be formed from the first two, or 

Data set n: no 

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example. 

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

Source


題目連結:http://poj.org/problem?id=2192

題目大意:問完全使用兩個字串A,B的字母,能否組成字串C,組成C串的字母順序遵從在A,B中的順序。

解題思路:這題的正解是DP或者記憶化搜尋,我用的是DFS+剪枝。兩個DFS,一個搜A串,搜尋成功後用另一個搜B串。剪枝:1.搜B串時是這樣的情況,如果有解,則C串中剩餘未搜的字母個數與順序應該與B串一樣,所以第二個搜尋不是深搜,而是直接線性判斷B,C串對應字母是否一樣。2.判斷C串最後一個字母是否為A或B串最後一個字母,若不是,直接判斷為no。

程式碼如下:

#include <cstdio>
#include <cstring>
char a[205],b[205],s[410];
int ns,na,nb;
bool q;
void dfsb()
{
	int n=0;
	for(int i=0;i<ns;i++)
	{
		if(s[i]=='0')
			continue;
		if(s[i]!=b[n])
			return;
		n++;
	}
	q=true;
}
void dfsa(int n,int st)
{
	if(q)
		return;
	if(na==n)
	{
		dfsb();
		return ;
	}
	for(int i=st;i<ns;i++)
	{
		if(s[i]==a[n])
		{
			int t=s[i];
			s[i]='0';
			dfsa(n+1,i+1);
			if(q)
				return;
			s[i]=t;
		}
	}
}
int main()
{
	freopen("in.txt","r",stdin);
	int t;
	scanf("%d",&t);
	for(int ca=1;ca<=t;ca++)
	{
		q=false;
		scanf("%s%s%s", a,b,s);
		ns=strlen(s),na=strlen(a),nb=strlen(b);
		if(ns!=nb+na||s[ns-1]!=a[na-1]&&s[ns-1]!=b[nb-1])
		{
			printf("Data set %d: no\n",ca);
			continue;
		}
		dfsa(0,0);
		if(q)
			printf("Data set %d: yes\n",ca);
		else
			printf("Data set %d: no\n",ca);
	}
	return 0;
}