1. 程式人生 > >hdoj1711(KMP模板題)Number Sequence

hdoj1711(KMP模板題)Number Sequence

Problem Description Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input 2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
Sample Output 6 -1 給出一個主序列,和一個匹配序列,如果能夠匹配,則輸出匹配序列第一個數在主序列中的位置. 這道題是kmp的基礎題. kmp演算法連結:http://www.cnblogs.com/c-cloud/p/3224788.html 程式碼如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int nextt[10010],T[10010];
int S[1000100];
int n,m,ans;
void get_next()
{
	int i=1,j=0;
	nextt[1]=0;//next 陣列的前兩項其實是可以直接算出來的,next[1]=0,next[1]=1; 
	while(i<m)
	{
		if(j==0||T[i]==T[j])//T[i]表示字尾單個字元,T[j]表示字首單個字元 
		{
			++i;
			++j;
			nextt[i]=j;
		}
		else
		j=nextt[j];//若字元不同,則j回溯 
	}
}
void kmp()
{
	int i=1,j=1;
	while(i<=n&&j<=m)
	{
		if(j==0||S[i]==T[j])
		{
			++i,++j;
		}
		else
		j=nextt[j];
	}
	if(j>m)
		printf("%d\n",i-m);
	else
   		printf("-1\n");
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		int i,j;
		for(i=1;i<=n;i++)
		scanf("%d",&S[i]);
		for(i=1;i<=m;i++)
		scanf("%d",&T[i]);
		S[0]=T[0]=-1;
		get_next();
		kmp();
	}
}