1. 程式人生 > >HDU 1001Sum Problem  (java)

HDU 1001Sum Problem  (java)

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 517127    Accepted Submission(s): 131131


Problem Description Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input The input will consist of a series of integers n, one integer per line.

Output For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input 1 100
Sample Output 1 5050
Author DOOM III 題意容易理解,注意下格式 類名必須是Main
import java.util.Scanner;  
class Main{  
  
    public static void main(String[] args) {
		
        Scanner sc = new Scanner(System.in);
		
        while(sc.hasNext()){
            long n = sc.nextInt();
            long sum = 0;  
            for(int i = 0; i<=n;i++){  
                sum+=i;  
            }  
            System.out.println(sum);  
            System.out.println(); 
        }  
    }  
  
}