1. 程式人生 > >hdu 4704 Sum(隔板+費馬小定理·大數取模)

hdu 4704 Sum(隔板+費馬小定理·大數取模)

Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1907    Accepted Submission(s): 794


Problem Description

Sample Input 2
Sample Output 2 Hint 1. For N = 2, S(1) = S(2) = 1. 2. The input file consists of multiple test cases. 開始真沒讀懂題意,我還以為S(k)是x1+x2+……+xk呢,原來是N個數劃分成k份的種數。
因此用到了隔板原理,n個數之間有n-1個間隔,分成1份:一個隔板都不用,C(n-1,0);分成兩份:用一個隔板,C(n-1,1);……;分成n份:用去所有的隔板,C(n-1,n-1)。所以結果就應該是[C(n-1,0,)+C(n-1,1)+……+C(n-1,n-1)]%mod. 看見C(n,m)我又想起了楊輝三角,當然這裡不能那麼幹,看見那個N我就打消了原來的念頭。。楊輝三角的一行的和(也就是C(n-1,0,)+C(n-1,1)+……+C(n-1,n-1))其實也等於(1+1)^(n-1)=2^(n-1)。這下問題就變成求解2^(n-1)%mod了。由於N太大,必須降冪,費馬小定理:假如p是質數,且(a,p)=1,那麼 a^(p-1)≡1(mod p)--> a^N%mod=a^(N%(mod-1))%mod。關於大數取模的方法:字串儲存原有的大數,再 ans = (ans * 10 + str[i] - '0')%mod; 因為原值就是在不斷減去mod倍。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=1e5+10,mod=1e9+7;
char str[maxn];
typedef long long LL;
LL power(int a,int p){
    LL ans=1,temp=a;
    while(p){
        if(p&1) ans=ans*temp%mod;
        temp=temp*temp%mod;
        p>>=1;
    }
    return ans;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    while(cin>>str){
         LL p=0,length=strlen(str);
         for(int i=0;i<length;i++){
             p=(p*10+str[i]-'0')%(mod-1);  //2與mod互質,mod是一個素數,可以使用費馬小定理
         }
         p=(p-1+mod-1)%(mod-1);
         printf("%lld\n",power(2,p));
    }
    return 0;
}