1. 程式人生 > >HDU5120 Intersection 【求圓的面積交】

HDU5120 Intersection 【求圓的面積交】

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 41    Accepted Submission(s): 22

Problem Description Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
Input The first line contains only one integer T (T ≤ 105
), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers xi, yi (0 ≤ xi, yi ≤ 20) indicating the coordinates of the center of each ring.
Output For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.

Sample Input 2 2 3 0 0 0 0 2 3 0 0 5 0
Sample Output Case #1: 15.707963 Case #2: 2.250778
Source

S = A大B大 - A大B小 - A小B大 + A小B小。(A表示A環,大表示大圓,B同)。然後直接套模板。

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <cmath>
using namespace std;

const double eps = 1e-8;
const double PI = acos(-1.0);

int sgn(double x)
{
    if(fabs(x) < eps) return 0;
    if(x < 0) return - 1;
    else return 1;
}
struct Point
{
    double x, y;
    Point(){}
    Point(double _x, double _y)
    {
        x = _x; y = _y;
    }
    Point operator -( const Point &b) const
    {
        return Point(x - b. x, y - b. y);
    }

    double operator ^ (const Point &b) const
    {
        return x*b. y - y*b. x;
    }

    double operator * (const Point &b) const
    {
        return x*b. x + y*b. y;
    }

    void transXY(double B)
    {
        double tx = x,ty = y;
        x = tx* cos(B) - ty*sin(B);
        y = tx* sin(B) + ty*cos(B);
    }
};

double dist( Point a, Point b)
{
    return sqrt((a-b)*(a- b));
}

double Ac(Point c1, double r1, Point c2, double r2)
{
    double d = dist(c1,c2);
    if(r1 + r2 < d + eps) return 0;
    if(d < fabs(r1 - r2) + eps)
    {
        double r = min(r1,r2);
        return PI*r*r;
    }
    double x = (d*d + r1*r1 - r2*r2)/(2*d);
    double t1 = acos(x / r1);
    double t2 = acos((d - x)/r2);
    return r1*r1*t1 + r2*r2*t2 - d*r1*sin(t1);
}

int main() {
    int T; Point c1, c2;
    double ans, r, R, x1, y1, x2, y2;
    scanf("%d", &T);
    for(int cas = 1; cas <= T; ++cas) {
        scanf("%lf%lf%lf%lf%lf%lf", &r, &R, &x1, &y1, &x2, &y2);
        c1.x = x1; c1.y = y1;
        c2.x = x2; c2.y = y2;
        ans = Ac(c1, R, c2, R) - Ac(c1, R, c2, r) - Ac(c1, r, c2, R)
                + Ac(c1, r, c2, r);
        printf("Case #%d: %.6lf\n", cas, ans);
    }
    return 0;
}