1. 程式人生 > >歐拉回路 HDU

歐拉回路 HDU

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2873    Accepted Submission(s): 1141


Problem Description Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.

Input Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
Output For each test case ,output the least groups that needs to form to achieve their goal.
Sample Input 3 3 1 2 2 3 1 3 4 2 1 2 3 4
Sample Output 1 2 Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group. 一個連通圖不會有奇數個奇數度頂點,畫一畫圖可以知道,假如一個連通圖所有點度數為偶數,答案為1,否則就是奇數度頂點的一半,累加求和。還不是很理解,慢慢搞吧。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;
vector<int> vec;
int vist[200010], deg[200010], odd[200010], par[200010];
int n, m;

void init()
{
    vec.clear();
    memset(vist, 0, sizeof(vist));
    memset(deg, 0, sizeof(deg));
    memset(odd, 0, sizeof(odd));
    for(int i = 1; i <= n; i++) par[i] = i;

}

int Find(int x)
{
    return x==par[x] ? x : par[x]=Find(par[x]);
}

void unite(int x, int y)
{
    int fx = Find(x);
    int fy = Find(y);
    if(fx == fy) return ;
    par[fx] = par[fy];
}

int main()
{
    while(~scanf("%d%d", &n, &m)) {
        init();
        for(int i = 0; i < m; i++) {
            int a, b;
            scanf("%d%d", &a, &b);
            deg[a]++;
            deg[b]++;
            unite(a, b);
        }
        for(int i = 1; i <= n; i++) {
            int fi = Find(i);
            if(!vist[fi]) {
                vec.push_back(fi);
                vist[fi] = 1;
            }
            if(deg[i]&1) odd[fi]++; // 有度數為奇數的則父節點+1
        }
        int ans = 0;
        for(int i = 0; i < vec.size(); i++) {
            int t = vec[i];
            if(deg[t] == 0) continue;
            if(odd[t] == 0) ans++;
            else ans += odd[t]/2;
        }
        printf("%d\n", ans);
    }
}