1. 程式人生 > >TOJ 4171 L-The math problem(水題)

TOJ 4171 L-The math problem(水題)

4171.   L-The math problem Time Limit: 1.0 Seconds   Memory Limit:65536K
Total Runs: 287   Accepted Runs:86

Given an array a with n intergers, please tell me the max(ajai),0ijn1max(aj−ai),0≤i≤j≤n−1.

Input

The input consists of multiple test cases. The first line contains an integer TT, indicating the number of test cases.(

1T1000)(1≤T≤1000)
Each case contains one integer NN.(0N107)(0≤N≤107). Then comes a line with N intergers ai(107ai107)ai(−107≤ai≤107)

Output

For each case only output the answer.

Sample Input

1
5
1 3 5 4 2

Sample Output

4

水題 直接掃一遍 維護最大差值

注意要看清題,j是大於等於i的

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
using namespace std;

int a[10000005];

int main()
{
	int t;
	while(~scanf("%d",&t))
	{
		while(t--){
			memset(a,0,sizeof(a));
			int n;
			scanf("%d",&n);
			for(int i=0;i<n;i++){
				scanf("%d",&a[i]);
			} 
			int max_dif=0;
			int minn=999999;
			for(int i=0;i<n;i++){
				if(minn>a[i]){
					minn=a[i];
				}
				if(a[i]-minn>max_dif){
					max_dif=a[i]-minn;
				}
			}
			printf("%d\n",max_dif);
		}
	}
	return 0;	
} 


相關推薦

TOJ 4171 L-The math problem

4171.   L-The math problem Time Limit: 1.0 Seconds   Memory Limit:65536KTotal Runs: 287   Accepted Runs:86 Given an array a with n int

l洛谷 P4144 大河的序列

col -o tro body ger ont 代碼 .org show 題目戳 Solution:   這題前面都是廢話,關鍵的一句就是本題求的是序列中連續一段的相與值(&)+相或值(|)最大,然後對這個值進行快速冪取模。考慮到兩個數相與最大能得到的就是這兩個

E - The Blocks Problem UVA - 101

num continue blog while break ++ log pos 很多 - 題目大意 先理解給出的四個移動方式: move a onto b:把木塊a、b上的木塊放回各自的原位,再把a放到b上; move a over b:把a上的木塊放回各

【2018ICPC南京網絡賽 A】An Olympian Math Problem數論題

for student number 數論 main num title mar ive Alice, a student of grade 6, is thinking about an Olympian Math problem, but she feels so de

HDU - 5974 A Simple Math Problem 數論 GCD

大於 case simple problem pan nbsp 因子 script not 題目描述: Given two positive integers a and b,find suitable X and Y to meet the conditions:

Ksusha the Squirrel

Ksusha the Squirrel is standing at the beginning of a straight road, divided into n sectors. The sectors are numbered 1 to n, from left to right.

The Blocks Problem 木塊問題 vector

題意:從左到右有n個木塊,編號為0~n-1  ,要求模擬一下四種操作(a,b是木塊的編號) **move a onto b:  把a和b上方的木塊全部歸位,然後把a摞在b上面。 **move a over b:  把a上方的木塊全部歸位,然後把a放在b所在木塊堆的頂部

A + B Problem HDU - 1000

Problem Description: Calculate A + B. Input:Each line will contain two integers A and B. Process to end of file. Output:For each case, output

杭電acm2058————The sum problemC語言

原題: Problem Description Given a sequence 1,2,3,……N, your job is to calculate all the possible sub-sequences that the sum of the

Math Problem————積分賽

Math Problem 描述 求:∑ni=1⌊aik⌋∑i=1n⌊aik⌋ ps: ⌊x⌋⌊x⌋表示x向下取整 輸入 第一行一個整數TT表示測試組數.(1≤T≤10)(1≤T≤10) 第二

poj1730 - Perfect Pth Powers完全平方數

ostream splay -- size 技術 () isp close for /* 以前做的一道水題,再做精度控制又出了錯///。。。 */ 題目大意: 求最大完全平方數,一個數b(不超過int範圍),n=b^p,使得給定n,p最大; 題目給你一個數n,求p ; 解題

51nod 1283 最小周長

com cin ide splay include 面積 nod lac eml 1283 最小周長 題目來源: Codility 基準時間限制:1 秒 空間限制:131072 KB 分值: 5 難度:1級算法題 收藏 關註 取消關註 一個矩形的面積為S,

1283 最小周長

img icon tdi mage div 一道 自己的 highlight 示例 1283 最小周長 題目來源: Codility 一個矩形的面積為S,已知該矩形的邊長都是整數,求所有滿足條件的矩形中,周長的最小值。例如:S = 24,那麽有{1 24} {2

51nod 1717 好數

n) 技術分享 iostream image def 復雜 cout std algorithm 題目: 看起來很復雜,其實就是有多少個素因子就翻轉多少次。 然後考慮到只有平方數有奇數個素因子。 一次過,上代碼把: #include <iost

【POJ】Cow Multiplication

i++ targe tar AS names += include stream org Cow Multiplication http://poj.org/problem?id=3673 題意:輸入兩個數A B,比如123和45 然後算123*45這個運算是指1*4

ACM_鬧鐘人生

class title sample ont TP 一點 出口 計算 進制 鬧鐘人生 Time Limit: 2000/1000ms (Java/Others) Problem Description: 已知一個時鐘一開始指向0點,順時針走了n個小時,求它最終所指

【藍橋杯】第六屆國賽C語言B組 1.積分之迷

水題 urn class %d names 風鈴 需要 藍橋 std 小明開了個網上商店,賣風鈴。共有3個品牌:A,B,C。為了促銷,每件商品都會返固定的積分。 小明開業第一天收到了三筆訂單:第一筆:3個A + 7個B + 1個C,共返積分:315第二筆:4個A + 10個

Finding LCM LightOJ - 1215

out printf n) tac vector tps cin cnblogs queue 這題和這題一樣。。。。。。只不過多了個數。。。 Finding LCM LightOJ - 1215 https://www.cnblogs.com/WTSRUVF/p/931

A - I Think I Need a Houseboat HDU - 1065

啊啊啊 scan 水題 put 開始 end code 題意 \n 題意:給你一個半圓,半圓以面積每年增加50平方英裏的速度擴張。問(x, y)在多少年後被覆蓋、 思路:emmm,其實最開始,還是打表的,因為每一年的半圓的半徑可以算出來。啊啊啊啊,其實這個方法是可以的。

【CodeForces - 215A】【Bicycle Chain】

題目: Vasya's bicycle chain drive consists of two parts: n stars are attached to the pedal axle, m stars are attached to the rea