1. 程式人生 > >Poj.2590 Steps【“英語題”,水】 2015/09/22

Poj.2590 Steps【“英語題”,水】 2015/09/22

Steps
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7825 Accepted: 3600

Description

One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step. 
What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

Input

Input consists of a line containing n, the number of test cases.

Output

For each test case, a line follows with two integers: 0 <= x <= y < 2^31. For each test case, print a line giving the minimum number of steps to get from x to y.

Sample Input

3
45 48
45 49
45 50

Sample Output

3
3
4

Source

同ZOJ1871
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

int main(){
    int from,to,t;
    cin>>t;
    while( t-- ){
        scanf("%d%d",&from,&to);
        int dis = to - from;
        if( !dis ){
            printf("0\n");
            continue;
        }
        int x = 0,i,step;
        for( i = 1 ; ; ++i ){
            if( x + i * 2 >= dis ) break;
            x += i*2;
        }
        step = i*2-2;
        if( x+i*2 == dis )
            printf("%d\n",step+2);
        else if( x+i >= dis )
            printf("%d\n",step+1);
        else printf("%d\n",step+2);
    }
    return 0;
}