1. 程式人生 > >hdu 2899 Strange fuction 【二分+數學函式求導】

hdu 2899 Strange fuction 【二分+數學函式求導】

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10131    Accepted Submission(s): 6835

Problem Description

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample input

2
100
200

Sample output

-74.4291
-178.8534

分析:這是一道數學題,也是第一道整理的二分題,開個頭!說白了,這道題就是讓你用數學知識求函式最小值。二分對精度控制一下即可。程式碼:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
double solve(double x,double y)
{
    return 6*pow(x,7) + 8*pow(x,6) + 7*pow(x,3) + 5*pow(x,2) - y*x;
}
double w(double x,double y)
{
    return 42*pow(x,6) + 48*pow(x,5) + 21*pow(x,2) + 10*x - y;
}

int main()
{
    ios::sync_with_stdio(false);
    int t;
    double l,r,mid; //第一次定義成了int,輸出結果都不顯示
    double y;
    cin>>t;
    while(t--)
    {
        cin>>y;
        l = 0;
        r = 100;
        mid = (l+r)/2;
        while(fabs(w(mid,y)) > 0.000001)
        {
            if(w(mid,y) >= 0) //這種情況說明一階倒數等於0的根在(l,mid)之間
            {
                r = mid;
                mid = (l+r)/2;
            }
            else //這種情況說明一階倒數等於0的根在(mid,r)之間
            {
                l = mid;
                mid = (l+r)/2;
            }
        }
        printf("%.4f\n",solve(mid,y)); //注意在G++中提交用%f
    }
    return 0;
}