1. 程式人生 > >第七屆山東省ACM省賽 A Julyed

第七屆山東省ACM省賽 A Julyed

Julyed

Time Limit: 2000MS Memory Limit: 65536KB

Problem Description

    Julyed is preparing for her CET-6. She has N words to remember, but there is only M days left. If she can’t remember all these words, she won’t pass CET-6. If she can’t pass CET-6, she will be unhappy. But if she remember too many words in one day, she will be unhappy, too. If she is unhappy, tomriddly will be unhappy. So she will remember as little words as she can in one day. For the happiness of both tomriddly and Julyed, how many words at most will Julyed remember in one day?

Input

 Multiple test cases. The first line is an integer T (T <= 10000), indicating the number of test cases.

Each test case is a line with two integers N, M (1 <= N, M <= 200), indicating the number of words to remember and the number of days left.

Output

 One line per case, an integer indicates the answer.

Example Input

5
6 3
1
5  
3

Example Output

2 2 1 3 2 

給出總作業數和每天最多做多少,問最少多少天做完。  向上取整即可

#include <iostream>

#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
    int t;
    double a,b;
    cin>>t;
    while(t--)
    {
        scanf("%lf%lf",&a,&b);
        cout<<ceil(a/b)<<endl;
    }
}




/***************************************************
User name: 譚澤純
Result: Accepted
Take time: 32ms
Take Memory: 240KB
Submit time: 2017-04-28 14:41:01
****************************************************/