1. 程式人生 > >HDU 2035 人見人愛A^B(快速冪取模 )

HDU 2035 人見人愛A^B(快速冪取模 )

人見人愛A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34030    Accepted Submission(s): 23080


Problem Description 求A^B的最後三位數表示的整數。
說明:A^B的含義是“A的B次方”
Input 輸入資料包含多個測試例項,每個例項佔一行,由兩個正整數A和B組成(1<=A,B<=10000),如果A=0, B=0,則表示輸入資料的結束,不做處理。 Output 對於每個測試例項,請輸出A^B的最後三位表示的整數,每個輸出佔一行。
Sample Input 2 3 12 6 6789 10000 0 0 Sample Output 8 984 1 Author lcy 題解:快速冪取模  AC程式碼:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
typedef long long LL;
using namespace std;
/*
int pow_mod(int a,int p)    //快速冪取模 
{
    if(p==0) return 1;
    int ans=pow_mod(a,p/2);
    ans=ans*ans%1000;
    if(p%2==1) ans=ans*a%1000;
    return ans;
}
*/
int pow_mod(LL a,LL b,int c){    //快速冪取模 
	LL ans=1;
	a=a%c;
	while(b>0){
		if(b&1){         //b&1相當於b%2==1
			ans=(ans*a)%c;
		}
		b=b>>1;  
        a=(a*a)%c;
	}
	return ans;
}
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        if(a==0&&b==0) break;
        printf("%d\n",pow_mod(a,b,1000));
    }
}
模擬:
#include<cstdio>
using namespace std;
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF)   
    {
        if(a==0&&b==0) break;
        int ans=1;
        for(int i=0;i<b;i++)   //模擬 
            ans=ans*a%1000;
        printf("%d\n",ans);
    }
}