1. 程式人生 > >HDU-5363 Key Set 【快速冪取模+遞推】

HDU-5363 Key Set 【快速冪取模+遞推】

Key Set

Time Limit:1000MS Memory Limit:131072KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
soda has a set S with n integers {1, 2, \dots, n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.

Input
There are multiple test cases. The first line of input contains an integer T (1 \le T \le 10^5), indicating the number of test cases. For each test case:

The first line contains an integer n (1 \le n \le 10^9), the number of integers in the set.

Output
For each test case, output the number of key sets modulo 1000000007.

Sample Input
4
1
2
3
4

Sample Output
0
1
3
7

  1. 題意:給定一個集合{1,2,3……n},求此集合的非空子集中 key set的個數對1000000007的餘數;key set:集合中所有的元素之和為偶數。
  2. 思路:遞迴思想:設集合{1 ,2,3……n}的key set個數為f(n),那麼{1,2,,3……,n-1}的key set個數為f(n-1). 討論: 1.n為偶數,f(n)=f(n-1)+f(n-1)+1; 2.n為奇數,f(n)=f(n-1)+2^(n-1)-1. 最後推匯出公式f(n)=2^(n-1)-1; 在這裡不再敘述,其實就是n這個元素加入到原來的·集合會產生多少·key set,沒思路的話舉例子也可以推出來(含n個元素的集合的冪集中的元素個數為2^n)
  3. 失誤:剛開確實沒思路,也不想舉例子。
  4. 程式碼如下:
#include<cstdio>

__int64 quickpow(__int64 base ,__int64 m,__int64 mod)
{
    __int64 ans=1;

    while(m>0)
    {
        if(m&1)
        {
            ans=(ans*base)%mod;
            --m; 
        }

        base=(base*base)%mod;
        m/=2;
    }

    return ans;
}

int main()
{
    __int64 t,n,c;
    scanf("%I64d",&t);

    while(t--)
    {
        scanf("%I64d",&n);

        c=quickpow(2,n-1,1000000007)-1;

        printf("%I64d\n",c);
    }
    return 0;
 }