1. 程式人生 > >hdu6112今夕何夕(日期類)

hdu6112今夕何夕(日期類)

今夕何夕

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1216    Accepted Submission(s): 431


Problem Description 今天是2017年8月6日,農曆閏六月十五。

小度獨自憑欄,望著一輪圓月,發出了“今夕何夕,見此良人”的寂寞感慨。

為了排遣鬱結,它決定思考一個數學問題:接下來最近的哪一年裡的同一個日子,和今天的星期數一樣?比如今天是8月6日,星期日。下一個也是星期日的8月6日發生在2023年。

小貼士:在公曆中,能被4整除但不能被100整除,或能被400整除的年份即為閏年。
Input 第一行為T,表示輸入資料組數。

每組資料包含一個日期,格式為YYYY-MM-DD。

1 ≤ T ≤ 10000

YYYY ≥ 2017

日期一定是個合法的日期


Output 對每組資料輸出答案年份,題目保證答案不會超過四位數。
Sample Input 3 2017-08-06 2017-08-07 2018-01-01
Sample Output 2023 2023 2024
Source 學到一個新的技能,察勒公式計算星期幾啊哈哈
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <iostream>
using namespace std;
int is_run(int year)
{
    if(year%400==0||(year%4==0&&year%100!=0))
        return 1;
    return 0;
}

int is_morth(int morth)
{
    if(morth==1||morth==3||morth==5||morth==7||morth==8||morth==10||morth==12)
        return 1;
    else if(morth==2)
        return 2;
    else return 0;
}
int Zeller(int year,int month,int day)///蔡勒公式算星期
{
    if (month==1||month==2)
    {
        year--;
        month+=12;
    }
    int c=year/100;
    int y=year-c*100;
    int week=(c/4)-2*c+(y+y/4)+(13*(month+1)/5)+day-1;
    while(week<0){week+=7;}
    week%=7;
    return week;
}
int main()
{
    int year,month,day,T;
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d-%d-%d",&year,&month,&day);
        int week=Zeller(year,month,day);
        int week2;
        if (month==2&&day==29)///如果輸入為閏年的2月29號
        {
            for (int i=year+4;i<=9999;i+=4)///每四年列舉
            {
                if (!is_run(i)) continue;///不是閏年就PASS
                week2=Zeller(i,month,day);
                if (week==week2)
                {
                    printf("%d\n",i);
                    break;
                }
            }
        }
        else
        {
            for (int i=year+1;i<=9999;i++)
            {
                week2=Zeller(i,month,day);
                if (week==week2)
                {
                    printf("%d\n",i);
                    break;
                }
            }
        }
    }
    return 0;
}