1. 程式人生 > >hdu 6112 今夕何夕(日期計算——蔡勒公式)

hdu 6112 今夕何夕(日期計算——蔡勒公式)

今夕何夕

Problem Description

今天是2017年8月6日,農曆閏六月十五。

小度獨自憑欄,望著一輪圓月,發出了“今夕何夕,見此良人”的寂寞感慨。

為了排遣鬱結,它決定思考一個數學問題:接下來最近的哪一年裡的同一個日子,和今天的星期數一樣?比如今天是8月6日,星期日。下一個也是星期日的8月6日發生在2023年。

小貼士:在公曆中,能被4整除但不能被100整除,或能被400整除的年份即為閏年。

Input

第一行為T,表示輸入資料組數。

每組資料包含一個日期,格式為YYYY-MM-DD。

1 ≤ T ≤ 10000

YYYY ≥ 2017

日期一定是個合法的日期

Output

對每組資料輸出答案年份,題目保證答案不會超過四位數。

Sample Input

3
2017-08-06
2017-08-07
2018-01-01

Sample Output

2023
2023
2024

思路:蔡勒公式
注意特判2月29,2月29要4年4年的加

程式碼:

#include<stdio.h>

bool leap(int y)
{
    if((y%4==0&&y%100!=0)||y%400==0)
        return true;
    return false;
}

int Zeller(int y,int m,int d)
{
    if(m<=2)
        m+=12,--y
; int a=y/100,b=y%100; int w=(a/4-2*a+b+b/4+13*(m+1)/5+d-1+700)%7; return w; } int main() { int t,y,m,d; scanf("%d",&t); while(t--) { scanf("%d-%d-%d",&y,&m,&d); int w=Zeller(y,m,d); if(m==2&&d==29) { for(int i=y+4
; i<=9999; i+=4) if(leap(i)) { if(Zeller(i,m,d)==w) { printf("%d\n",i); break; } } } else { for(int i=y+1; i<=9999; ++i) if(Zeller(i,m,d)==w) { printf("%d\n",i); break; } } } return 0; }



ps:還可以模擬著寫

程式碼:

#include<stdio.h>

int leap(int y)
{
    if((y%4==0&&y%100!=0)||y%400==0)
        return 1;
    return 0;
}

int main()
{
    int t,y,m,d;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d-%d-%d",&y,&m,&d);
        int tot=0;
        if(m==2&&d==29)
        {
            while(1)
            {
                y+=4;
                tot=(tot+365*4+leap(y))%7;
                if(!tot&&leap(y))//注意這裡要判斷閏年
                    break;
            }
        }
        else
        {
            while(1)
            {
                if(m>2)
                    tot=(tot+365+leap(y+1))%7;
                else
                    tot=(tot+365+leap(y))%7;
                ++y;
                if(!tot)
                    break;
            }
        }
        printf("%d\n",y);
    }
    return 0;
}