1. 程式人生 > >1007: 童年生活二三事

1007: 童年生活二三事

Description

Redraiment小時候走路喜歡蹦蹦跳跳,他最喜歡在樓梯上跳來跳去。
但年幼的他一次只能走上一階或者一下子蹦上兩階。
現在一共有N階臺階,請你計算一下Redraiment從第0階到第N階共有幾種走法。

Input

輸入包括多組資料。
每組資料包括一行:N(1≤N≤40)。
輸入以0結束。

Output

對應每個輸入包括一個輸出。
為redraiment到達第n階不同走法的數量。

Sample Input

1
2
0

Sample Output

1
2
MyCode:
#include <iostream>

using namespace std;

int main( void )
{
	int num;
	int array[41 ]= { 0, 1, 2 };
	
	while(( cin>>num ), num!= 0 )
	{
		if( num== 1 || num== 2 )
		{
			cout<< array[ num ]<< endl;
		}
		else
		{
			int i;
			
			for( i= 3; i<= num; i++ )
			{
				array[ i ]= array[ i- 1 ]+array[ i- 2];
			}
			
			cout<< array[ num ]<< endl;
		}
	}
	
	return 0;
}