1. 程式人生 > >1018 Public Bike Management (30)(30 分)(C++)

1018 Public Bike Management (30)(30 分)(C++)

1018 Public Bike Management (30)(30 分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect

 condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

\ Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S~3~, we have 2 different shortest paths:

1. PBMC -> S~1~ -> S~3~. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S~1~ and then take 5 bikes to S~3~, so that both stations will be in perfect conditions.

2. PBMC -> S~2~ -> S~3~. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C~max~ (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; S~p~, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C~i~ (i=1,...N) where each C~i~ is the current number of bikes at S~i~ respectively. Then M lines follow, each contains 3 numbers: S~i~, S~j~, and T~ij~ which describe the time T~ij~ taken to move betwen stations S~i~ and S~j~. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0-&gtS~1~->...-&gtS~p~. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S~p~ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

解題思路:作為一個管理員,現給定一個終點,你要選擇最短路徑到這個點,很明顯是Dijsktra的使用。但是重點在下面,同時這一路上我們要把所有節點的權值都調節至最佳。另一方面,最短路徑不一定唯一,因此我們用pre陣列先儲存所有路徑,再用DFS遍歷,選擇最後帶回的車輛最少的那條路。

#include <iostream>
#include <vector>
using namespace std;
const int inf=999999999;
int full,n,sp,m,rsend=inf,rtake=inf,tempsend,temptake;
std::vector<int> result,temp;
int w[505],e[505][505],dis[505];
bool visit[505];
std::vector<int> pre[505];
void dfs(int index){
    if(index==0){
        temptake=0;tempsend=0;
        for(int j=temp.size()-1;j>=0;j--){
            temptake+=(w[temp[j]]-full);
            if(temptake<0){
                tempsend-=temptake;
                temptake=0;
            }
        }
        if(tempsend<rsend){
            rtake=temptake;
            rsend=tempsend;
            result=temp;
        }
        else if(tempsend==rsend&&temptake<rtake){
            rtake=temptake;
            rsend=tempsend;
            result=temp;
        }
        return;
    }
    temp.push_back(index);
    for(int i=0;i<pre[index].size();i++)
        dfs(pre[index][i]);
    temp.pop_back();
}
int main(){
    scanf("%d %d %d %d",&full,&n,&sp,&m);
    full/=2;
    fill(e[0],e[0]+505*505,inf);
    fill(dis,dis+505,inf);
    for(int i=1;i<=n;i++)
        scanf("%d",&w[i]);
    for(int i=0;i<m;i++){
        int a,b,temp;
        scanf("%d %d %d",&a,&b,&temp);
        e[a][b]=temp;e[b][a]=temp;
    }
    dis[0]=0;
    for(int i=0;i<=n;i++){
        int u=-1,min=inf;
        for(int j=0;j<=n;j++){
            if(visit[j]==false&&dis[j]<min){
                u=j;
                min=dis[j];
            }
        }
        if(u==-1)
            break;
        visit[u]=true;
        for(int v=0;v<=n;v++){
            if(visit[v]==false&&e[v][u]!=inf){
                if(dis[u]+e[u][v]<dis[v]){
                    pre[v].clear();
                    pre[v].push_back(u);
                    dis[v]=dis[u]+e[u][v];
                }
                else if(dis[u]+e[u][v]==dis[v])
                    pre[v].push_back(u);
            }
        } 
    }
    dfs(sp);
    printf("%d 0",rsend);
    for(int i=result.size()-1;i>=0;i--)
        printf("->%d",result[i]);
    printf(" %d",rtake);
}