1. 程式人生 > >FZOJ Problem 2148 Moon Game

FZOJ Problem 2148 Moon Game

坐標 title ado draw pla nes scrip lin spec

Problem 2148 Moon Game

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game in the clearly blue sky which we can just consider as a kind of two-dimensional plane. Then Fat brother starts to draw N starts in the sky which we can just consider each as a point. After he draws these stars, he starts to sing the famous song “The Moon Represents My Heart” to Maze.

You ask me how deeply I love you,

How much I love you?

My heart is true,

My love is true,

The moon represents my heart.

But as Fat brother is a little bit stay-adorable(呆萌), he just consider that the moon is a special kind of convex quadrilateral and starts to count the number of different convex quadrilateral in the sky. As this number is quiet large, he asks for your help.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains an integer N describe the number of the points.

Then N lines follow, Each line contains two integers describe the coordinate of the point, you can assume that no two points lie in a same coordinate and no three points lie in a same line. The coordinate of the point is in the range[-10086,10086].

1 <= T <=100, 1 <= N <= 30

Output

For each case, output the case number first, and then output the number of different convex quadrilateral in the sky. Two convex quadrilaterals are considered different if they lie in the different position in the sky.

Sample Input

2 4 0 0 100 0 0 100 100 100 4 0 0 100 0 0 100 10 10

Sample Output

Case 1: 1 Case 2: 0 題意:在坐標圖上標記好n個點,現在由這n個點中任意的四個組成四邊形,窮盡所有的可能,問n個點總共能產生多少個凸四邊形。 思路:假定取出了一個四邊形,用四邊形的四個頂點組成三角形,一共可以組成4個三角形,如果是凹四邊形,則一定存在其中一個三角形的面積是其余三個三角形的面積之和。 已知三角形的三個頂點的坐標,由行列式 |1 1 1 | 計算可得三角形的面積。 |x1 x2 x3 |*1/2 |y1 y2 y3 | AC代碼:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>
#include<queue>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
const int N_MAX = 30+ 5;
int n;
pair<ll, ll>cor[N_MAX];

ll fab(ll a) {
    return a >= 0 ? a : -a;
}

int S(int a,int b,int c) {
    return fab(cor[a].first*(cor[b].second-cor[c].second)+cor[b].first*(cor[c].second-cor[a].second)+cor[c].first*(cor[a].second-cor[b].second)) ;
}

bool judge(int a,int b,int c,int d) {
    if (S(a, b, c) == S(a, b, d) + S(a, c, d) + S(b, c, d))
        return false;//凹四邊形
    return true;
}


int main() {
    int T;
    scanf("%d", &T);
    int cs = 0;
    while (T--) {
        cs++;
        scanf("%d",&n);
        for (int i = 0; i < n;i++) {
            scanf("%lld%lld",&cor[i].first,&cor[i].second);
        }
        int num = 0;
        for (int i = 0; i < n;i++) 
        for (int j = i + 1; j < n;j++) 
        for (int k = j + 1; k < n;k++) 
        for (int l = k + 1; l < n; l++) 
            if (judge(i, j, k, l) &&judge(j,i,l,k)&&judge(k,l,i,j)&&judge(l,k,j,i) ) {
                num++;
        }

        printf("Case %d: %d\n",cs,num);
    }
    return 0;
}

FZOJ Problem 2148 Moon Game