1. 程式人生 > >FZOJ Problem 2150 Fire Game

FZOJ Problem 2150 Fire Game

gin line bool include date log mini ould 最短

Problem 2150 Fire Game

Accept: 2185 Submit: 7670
Time Limit: 1000 mSec Memory Limit : 32768 KB

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4 3 3 .#. ### .#. 3 3 .#. #.# .#. 3 3 ... #.# ... 3 3 ### ..# #.#

Sample Output

Case 1: 1 Case 2: -1 Case 3: 0 Case 4: 2 題意:兩個“變態”在給定的區域內燒草坪,給定區域為N*M的矩形陣,起先兩個人同時各選定矩陣中的一塊草坪並開始燒,並且火會蔓延,只考慮當前草坪的上下左右四個格子,如果這些臨近的格子中有草坪,那麽火會蔓延至臨近的格子中,此時火延續的時間加1. 問兩個人分別應該選定哪兩塊草坪開始燒,使得火以最短的時間燒完矩陣中所有的草坪,如果火滅了任然還有草坪沒被燒,則判定為失敗,輸出-1,否則輸出火的最短延續時間. 思路:廣度優先搜索,從兩個點起始點同時開始搜索即可。 AC代碼:
#define _CRT_SECURE_NO_DEPRECATE
#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#include<cstring>
using namespace std;
const int N_MAX = 10+ 2;
int N,M;
char field[N_MAX][N_MAX];
bool vis[N_MAX][N_MAX];
int dx[4] = { -1,1,0,0 };
int dy[4] = { 0,0,-1,1 };
queue<pair<int,int> >que;
int num[N_MAX][N_MAX];

int bfs(int x1,int y1,int x2,int y2) {//返回 燒完所有草需要的時間
    memset(vis, 0, sizeof(vis));//記錄走過的點
    memset(num, 0, sizeof(num));//記錄到達某點的時間
    int Max=0;
    que.push(make_pair(x1,y1));
    que.push(make_pair(x2, y2));
    vis[x1][y1] = vis[x2][y2] = 1;
    while (!que.empty()) {
        int xx=que.front().first;
        int yy = que.front().second;
        que.pop();
        for (int i = 0; i < 4; i++) {
            int x = xx + dx[i];
            int y = yy + dy[i];
            if (x >= 0 && x < N&&y >= 0 && y < M&&!vis[x][y]&&field[x][y] == #) {
                vis[x][y] = true;
                que.push(make_pair(x, y));
                num[x][y] = num[xx][yy]+1;
                if (Max < num[x][y])Max = num[x][y];
            }
        }
    }
    for (int i = 0; i < N;i++) 
        for (int j = 0; j < M; j++) 
            if (field[i][j] == #&&!vis[i][j]) {
                Max = INT_MAX;
            }

    return Max;
}

int main() {
    int T,number;
    scanf("%d", &T);
    int cs = 0;
    while (T--) {
        number = 0;
        cs++;
        scanf("%d%d",&N,&M);
        memset(field, 0, sizeof(field));    
        for (int i = 0; i < N;i++) {
            for (int j = 0; j < M;j++) {
                scanf(" %c",&field[i][j]);
                if (field[i][j] == #)
                    number++;
            }
        }
        if (number <= 2) {//!!!!草坪數小於2不用搜索了
            printf("Case %d: %d\n", cs, 0);
            continue;
        }
        int min_time=INT_MAX;
        for (int i = 0; i < N*M;i++) {
            int x1 = i / M; int y1 = i%M;
            if (field[x1][y1] != #)continue;
            for (int j = i+1; j < N*M;j++) {
                int x2 = j / M; int y2 = j%M;
                if (field[x2][y2] != #)continue;
                int tmp= bfs(x1, y1, x2, y2);
                if (tmp < min_time)
                    min_time = tmp;
            }
        }
        
        if (min_time == INT_MAX)min_time = -1;
        printf("Case %d: %d\n",cs,min_time);
        
    }
    return 0;
}

FZOJ Problem 2150 Fire Game