1. 程式人生 > >poj 2531 Network Saboteur (dfs)

poj 2531 Network Saboteur (dfs)

sin number work res queue win 百度 ces rst

Network Saboteur
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9364 Accepted: 4417

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

百度了一下才知道思路,繼續努力。

。。

題意:把一個連通的集合分成兩個不連通的集合。求這兩個集合間最大的信息交換量。

每一個點(電腦)能夠由兩個選擇。分給A集合或者B集合。

每次把一個點分類後。馬上求出它和還有一個集合的交換信息量。


#include<stdio.h>
#include<queue>
#include<map>
#include<string>
#include<string.h>
using namespace std;
#define N 25
const int inf=0x1f1f1f1f;
int g[N][N];
int ans,n;
bool f[N];
void dfs(int u,int sum)
{
    if(u>=n)
    {
        ans=max(ans,sum);
        return ;
    }
    int i,tmp=0;
    f[u]=false;         //把點U分為集合A
    for(i=0;i<u;i++)   //求點U和集合B交換的信息量
        if(f[i]==true)
            tmp+=g[u][i];
    dfs(u+1,sum+tmp);
    f[u]=true;          //把點U分為集合B
    for(i=tmp=0;i<u;i++) //求點U和集合A交換的信息量
        if(f[i]==false)
        tmp+=g[u][i];
    dfs(u+1,sum+tmp);
}
int main()
{
    int i,j;
    while(scanf("%d",&n)!=-1)
    {
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                scanf("%d",&g[i][j]);
        ans=0;
        dfs(0,0);
        printf("%d\n",ans);
    }
    return 0;
}


poj 2531 Network Saboteur (dfs)