1. 程式人生 > >Problem J: 求個最大值

Problem J: 求個最大值

main oid 整數 stream con spa ++ gre 其中

Problem J: 求個最大值

Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 871 Solved: 663
[Submit][Status][Web Board]

Description

定義MaxValue類,用於求一系列非零整數的最大值。其中:

1. 數據成員elements用於存儲所有輸入的非零整數。

2. void append(int)用於向elements中添加一個新數據。

3. int getMax()用於求出elements中的最大值。

Input

輸入若幹個整數,以輸入0表示輸入結束。

Output

所有輸入的非零整數中的最大值。

Sample Input

321 496 553 338 837 463 158 154 929 537 0

Sample Output

929

HINT

使用vector更為容易實現。


Append Code

append.cc,
#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
using namespace std;
#define maxn 10000
int ipos=0;
class MaxValue
{
public:
    int a[maxn];
    void append(int t)
    {
        a[ipos++]=t;
    }
    int getMax()
    {
    return *max_element(a,a+ipos);
    }
};
int main()
{
    int a;
    MaxValue test;
    cin>>a;
    while (a != 0)
    {
        test.append(a);
        cin>>a;
    }
    cout<<test.getMax()<<endl;
    return 0;
}

  

Problem J: 求個最大值