1. 程式人生 > >POJ 3264 Balanced Lineup(線段樹—求區間最大值與最小值差)

POJ 3264 Balanced Lineup(線段樹—求區間最大值與最小值差)

Balanced Lineup

Time Limit:5000MS

Memory Limit:65536K

Total Submissions:41077

Accepted:19305

Case Time Limit:2000MS

Description

For the daily milking, Farmer John'sNcows (1 ≤N≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list ofQ(1 ≤Q≤ 200,000) potential groups of cows and their heights (1 ≤height≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,NandQ.
Lines 2..N+1: Linei
+1 contains a single integer that is the height of cowi
LinesN+2..N+Q+1: Two integersAandB(1 ≤ABN), representing the range of cows fromAtoBinclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

題意:有一群排成一列的奶牛,讓找出某個區間內奶牛們的最高身高與最低身高的差值。

題解:線段樹問題,不能分別查詢最大值,最小值,很耗時。與南陽上士兵殺敵(三)問題相同。

程式碼如下:

#include<cstdio>
#define INF 0x3f3f3f3f
int Max,Min;
struct node
{
	int left,right,max,min;
}num[200000];

int MAX(int a,int b)
{
	return a>b?a:b;
}

int MIN(int a,int b)
{
	return a<b?a:b;
}

void build(int left,int right,int cnt)
{
	int mid;
	num[cnt].left=left;
	num[cnt].right=right;
	if(left==right)
	{
		scanf("%d",&num[cnt].max);
		num[cnt].min=num[cnt].max;
		return ;
	}
	mid=(left+right)>>1;
	build(left,mid,cnt*2);
	build(mid+1,right,cnt*2+1);
	num[cnt].max=MAX(num[cnt*2].max,num[cnt*2+1].max);
	num[cnt].min=MIN(num[cnt*2].min,num[cnt*2+1].min);
}

void query(int left,int right,int cnt)
{
	int  mid;
	if(left==num[cnt].left&&right==num[cnt].right)
	{
		Max=MAX(Max,num[cnt].max);
		Min=MIN(Min,num[cnt].min);
		return ;
	}
	mid=(num[cnt].left+num[cnt].right)>>1;
	if(right<=mid)
		query(left,right,cnt*2);
	else if(left>mid)
		query(left,right,cnt*2+1);
	else
	{
		query(left,mid,cnt*2);
		query(mid+1,right,cnt*2+1);
	}	
}

int main()
{
	int N,Q,a,b;
	while(scanf("%d%d",&N,&Q)!=EOF)
	{
		build(1,N,1);
		while(Q--)
		{
			scanf("%d%d",&a,&b);
			Max=-1;
			Min=INF;
			query(a,b,1);
			printf("%d\n",Max-Min);
		}
	}
	return 0;
}