1. 程式人生 > >POJ 3264 Balanced Lineup

POJ 3264 Balanced Lineup

represent sca play ems urn rep ide single indicate

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 33094 Accepted: 15552
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2..N
+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

打算用兩種方法做。順便差別一下,RMQ和線段樹的差別。他們都都說RMQ比線段樹好,我發現時間也差不了多少,盡管都沒優化


AC代碼例如以下:


線段樹。

///線段樹   2250MS   2404K

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define  M 50010
#define inf 100000000
using namespace std;

struct H
{
    int l,r,maxx,minn;
}trees[4*M];

int n,m;
int num[M];

void build_trees(int jd ,int l,int r)
{
    trees[jd].l=l;trees[jd].r=r;
    if(l==r)
    {
        trees[jd].maxx=num[l];
        trees[jd].minn=num[l];
        return ;
    }
    int mid = (l+r)/2;
    build_trees(jd*2,l,mid);
    build_trees(jd*2+1,mid+1,r);
    trees[jd].maxx=max(trees[jd*2].maxx,trees[jd*2+1].maxx);
    trees[jd].minn=min(trees[jd*2].minn,trees[jd*2+1].minn);
}

int query_max(int jd,int l,int r)
{
    int ans=0;
    if(l<=trees[jd].l&&r>=trees[jd].r)
        return trees[jd].maxx;
    int mid = (trees[jd].l+trees[jd].r)/2;
    if(l<=mid) ans=max(ans,query_max(jd*2,l,r)) ;
    if(r>mid) ans=max(ans,query_max(jd*2+1,l,r));
    return ans;
}

int query_min(int jd,int l,int r)
{
    int ans=inf;
    if(l<=trees[jd].l&&r>=trees[jd].r)
        return trees[jd].minn;
    int mid = (trees[jd].l+trees[jd].r)/2;
    if(l<=mid) ans=min(ans,query_min(jd*2,l,r)) ;
    if(r>mid) ans=min(ans,query_min(jd*2+1,l,r));
    return ans;
}

int main()
{
    int i,j;
    int a,b;
    while(~scanf("%d%d",&n,&m))
    {
        memset(num,0,sizeof num);
        for(i=1;i<=n;i++)
        scanf("%d",&num[i]);
        build_trees(1,1,n);
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&a,&b);
            printf("%d\n",query_max(1,a,b)-query_min(1,a,b));
        }
    }
    return 0;
}


RMQ!。!


///RMQ  1813MS  12100K

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define  M 50010
#define inf 100000000
using namespace std;

int n,m;
int num[M];
int dp1[M][30],dp2[M][30];

void RMQ_min()
{
    int i,j;
    memset(dp1,0,sizeof dp1);
    for(i=1;i<=n;i++)
        dp1[i][0]=num[i];
    for(j=1;1<<j<=n;j++)
        for(i=1;i+(1<<j)-1<=n;i++)
            dp1[i][j]=min(dp1[i][j-1],dp1[i+(1<<(j-1))][j-1]);
}

void RMQ_max()
{
    int i,j;
    memset(dp2,0,sizeof dp2);
    for(i=1;i<=n;i++)
        dp2[i][0]=num[i];
    for(j=1;1<<j<=n;j++)
        for(i=1;i+(1<<j)-1<=n;i++)
            dp2[i][j]=max(dp2[i][j-1],dp2[i+(1<<(j-1))][j-1]);
}

int rmq_min(int l,int r)
{
    int i,j;
    int k=0;
    while(1<<(k+1)<=r-l+1)
        k++;
    return min(dp1[l][k],dp1[r-(1<<k)+1][k]);
}

int rmq_max(int l,int r)
{
    int i,j;
    int k=0;
    while(1<<(k+1)<=r-l+1)
        k++;
    return max(dp2[l][k],dp2[r-(1<<k)+1][k]);
}

int main()
{
    int i,j;
    int a,b;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=1;i<=n;i++)
            scanf("%d",&num[i]);
            RMQ_min();
            RMQ_max();
            for(i=1;i<=m;i++)
            {
                scanf("%d%d",&a,&b);
                printf("%d\n",rmq_max(a,b)-rmq_min(a,b));
            }

    }
    return 0;
}




POJ 3264 Balanced Lineup