1. 程式人生 > >Problem A: 求個最大值

Problem A: 求個最大值

public lang TP problem inpu mem sam 數據 Go

Problem A: 求個最大值

Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 1635 Solved: 1339
[Submit][Status][Web Board]

Description

定義MaxValue類,用於求一系列非零整數的最大值。其中:

1. 數據成員elements用於存儲所有輸入的非零整數。

2. void append(int)用於向elements中添加一個新數據。

3. int getMax()用於求出elements中的最大值。

Input

輸入若幹個整數,以輸入0表示輸入結束。

Output

所有輸入的非零整數中的最大值。

Sample Input

321
496
553
338
837
463
158
154
929
537
0

  

Sample Output

929

HINT

使用vector更為容易實現。


Append Code

append.cc,
int main()
{
    int a;
    MaxValue test;
    cin>>a;
    while (a != 0)
    {
        test.append(a);
        cin>>a;
    }
    cout<<test.getMax()<<endl;
    return 0;
}

  

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
class MaxValue
{
public :
    vector<int> elements;
    void append(int num)
    {
        elements.push_back(num);
    }
     int getMax()
     {
         sort(elements.begin(), elements.end());//排序
         return elements.back();//返回最後一個元素
     }
};
int main()
{
    int a;
    MaxValue test;
    cin>>a;
    while (a != 0)
    {
        test.append(a);
        cin>>a;
    }
    cout<<test.getMax()<<endl;
    return 0;
}

  

Problem A: 求個最大值