1. 程式人生 > >Choose the best route HDU杭電2680【dijkstra算法 || SPFA】

Choose the best route HDU杭電2680【dijkstra算法 || SPFA】

ace suppose include ria fine main from def wan

http://acm.hdu.edu.cn/showproblem.php?pid=2680

Problem Description One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
Input There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
Sample Input
5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output
1
-1

//這樣的方法能夠多個起點找最短路徑。省時間

//Dijkstra

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
int map[1010][1010];
int dis[20200];
bool used[20200];
int n;
int e;
int dijkstra()
{
	int i,j;
	memset(used,0,sizeof(used));
	for(i=0;i<=n;++i)
		dis[i]=INF;
	int pos;
	for(i=0;i<=n;++i)//第一次給dis賦值 
	{
		dis[i]=map[0][i];
	}
	dis[0]=0;
	used[0]=1;
	for(i=0;i<n;++i)//最多執行n次 
	{
		int min=INF;
		for(j=0;j<=n;++j)
		{
			if(!used[j]&&dis[j]<min)
			{
				min=dis[j];
				pos=j;
			}
		} 
		used[pos]=1;
		if(pos==e) return dis[pos];
		for(j=0;j<=n;++j)//把dis數組更新。也叫松弛
		{
			if(!used[j]&&dis[j]>map[pos][j]+dis[pos])
			{
				dis[j]=map[pos][j]+dis[pos];
			}
		}
	}
	return -1;
}
int main()
{
	int m,s,T;
	int u,v,w;
	int temp;
	int i,j;
	while(~scanf("%d%d%d",&n,&m,&e))
	{		
		for(i=0;i<=n;++i)
      		for(j=0;j<=i;++j)
        		map[i][j]=map[j][i]=INF;
		for(i=1;i<=m;++i)
		{
			scanf("%d%d%d",&u,&v,&w);
			if(map[u][v]>w)
				map[u][v]=w;
		}		
		scanf("%d",&T);
		for(i=1;i<=T;++i)
		{
			scanf("%d",&temp);
			map[0][temp]=0;//0指向要找的原點 
		}
		int ans=dijkstra();//萬能源點0 
		if(ans==-1)printf("-1\n");
		else printf("%d\n",ans);
	}
	return 0;
}

//SPFA


#include <cstdio>
#include <cstring>
#include <queue>
#define MAXN 1100
#define MAXM 22000
#define INF 0x3f3f3f3f
using namespace std;
int map[MAXN][MAXN];
int vis[MAXN];//推斷是否增加隊列了 
int num;
int low[MAXM];//存最短路徑 
int e;
int M, N;
void SPFA()
{
	int i, j;
	queue<int> Q;
	memset(low, INF, sizeof(low)); 
	memset(vis, 0, sizeof(vis));	
	vis[0] = 1;
	low[0] = 0;
	Q.push(0);
	while(!Q.empty())
	{
		int u = Q.front();
		Q.pop();
		vis[u] = 0;//出隊列了。不在隊列就變成0 
		for(i = 1; i <= N; ++i)
		{
			
			if(low[i] > low[u] + map[u][i])
			{
				low[i] = low[u] + map[u][i];
				if(!vis[i])				 
			 	{
			 		vis[i]=1;
			 		Q.push(i);
			 	}
			}
		}
	}
	if(low[e] == INF) printf("-1\n");
	else printf("%d\n",low[e]);
}
int main()
{
	int u, v, w;
	while(~scanf("%d%d%d", &N, &M, &e))
	{
		for(int i=0; i<=N;++i)
			for(int j=0;j<=i;++j)
				map[i][j]=map[j][i]=INF;
		while(M--)
		{
			scanf("%d%d%d", &u, &v, &w);
			if(map[u][v]>w)//一定要判重 
				map[u][v]=w;
//			map[u][v]=w;
//			map[v][u]=w;
		}
		int T,s;
		scanf("%d",&T);	
		while(T--)
		{
			scanf("%d",&s);
			map[0][s]=0;//萬能源點 
		}	
		SPFA();
	}
	return 0;
}

Choose the best route HDU杭電2680【dijkstra算法 || SPFA】