1. 程式人生 > >有向圖變為強連通圖 hdu2767

有向圖變為強連通圖 hdu2767

ebr tdi follow accep out ron des continue style

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7346 Accepted Submission(s): 2539


Problem Description Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input 2 4 0 3 2 1 2 1 3

Sample Output 4 2 找出所有的強連通分量, 然後縮成一個點,然後統計縮點之後的新圖的出度為0的點的個數(記為cntOut),和入度為0的點的個數(記為cntIn)

    那麽要加邊的條數就是max(cntOut,cntIn)

    這個為什麽呢?? 因為,如果一個點的入度為0,那麽說明這個點是不可達的,如果一個點的出度為0,那麽說明這個點到其它點是不可達的。

    為了解決這個情況,那麽只要在出度為0的點(設為u)和入度為0的點之間連一條u-->v的邊,那麽就解決了這種情況。

    不斷的連邊,只要一個點問題沒解決就要連邊, 所以是在兩者之間取max 此段論述http://www.cnblogs.com/justPassBy/p/4678192.html轉自這裏

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=20008;
const int M=50008;
int head[N],bl[N],q[N],dfn[N],low[N];
int tot,scnt,cnt,l,n,m;
bool instack[N],ru[N],out[N];
struct node{
   int to,next;
}e[M];
void init(){
   for(int i=0;i<=n;++i) {
    head[i]=-1;
    dfn[i]=instack[i]=0;
    ru[i]=out[i]=0;
   }
   l=tot=scnt=cnt=0;
}
void add(int u,int v){
   e[tot].to=v;
   e[tot].next=head[u];
   head[u]=tot++;
}
void Tajan(int u){
   dfn[u]=low[u]=++cnt;
   instack[u]=1;
   q[l++]=u;
   for(int i=head[u];i+1;i=e[i].next){
    int v=e[i].to;
    if(!dfn[v]) {
        Tajan(v);
        low[u]=min(low[u],low[v]);
    }
    else if(instack[v]&&dfn[v]<low[u])
        low[u]=dfn[v];
   }
   if(low[u]==dfn[u]){
    int t;
    ++scnt;
    do{
        t=q[--l];
        instack[t]=0;
        bl[t]=scnt;
    }while(t!=u);
   }
}
int main(){
    int u,v,T;
    for(scanf("%d",&T);T--;){
        scanf("%d%d",&n,&m);init();
        for(int i=1;i<=m;++i)
        {
            scanf("%d%d",&u,&v);
            add(u,v);
        }
        for(int i=1;i<=n;++i)
            if(!dfn[i]) Tajan(i);
            if(scnt==1) {puts("0");continue;}
        for(int i=1;i<=n;++i){
            for(int j=head[i];j+1;j=e[j].next){
                int v=e[j].to;
                if(bl[i]==bl[v]) continue;
                else {
                    ru[bl[v]]=1;
                    out[bl[i]]=1;
                }
            }
        }
        int ans1=0,ans2=0;
        for(int i=1;i<=scnt;++i){
            if(!out[i]) ++ans1;
            if(!ru[i]) ++ans2;
        }
        printf("%d\n",max(ans1,ans2));
    }
}

有向圖變為強連通圖 hdu2767